summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2015-09-11 12:22:33 +0200
committerMaxime Gauduin2015-09-11 12:22:33 +0200
commitf21f769e16285b265822709eb12837d7c09cebc5 (patch)
tree14e1f49b3d40c4e31ed932ebfff7b151982ea7ed
downloadaur-f21f769e16285b265822709eb12837d7c09cebc5.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--MKPKG4
-rw-r--r--PKGBUILD42
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c51b6cdc08a3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = switchboard-plug-notifications
+ pkgdesc = Notifications plug for Switchboard
+ pkgver = 0.1.0.1
+ pkgrel = 1
+ url = https://launchpad.net/switchboard-plug-applications
+ arch = i686
+ arch = x86_64
+ groups = pantheon
+ license = GPL3
+ makedepends = cmake
+ makedepends = vala
+ depends = glib2
+ depends = glibc
+ depends = gtk3
+ depends = libgee
+ depends = libgranite.so
+ depends = libswitchboard-2.0.so
+ source = https://launchpad.net/switchboard-plug-notifications/freya/0.1.0.1/+download/switchboard-plug-notifications-0.1.0.1.tar.xz
+ sha256sums = da5d543492747d9231d3c288324eab9715716c81aa786061c542514725f487ac
+
+pkgname = switchboard-plug-notifications
+
diff --git a/MKPKG b/MKPKG
new file mode 100644
index 000000000000..f62dbe04337e
--- /dev/null
+++ b/MKPKG
@@ -0,0 +1,4 @@
+pkgname=('switchboard-plug-notifications')
+builddeps=('switchboard')
+
+# vim: ts=2 sw=2 et:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b2f9831a4d6d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=switchboard-plug-notifications
+pkgver=0.1.0.1
+pkgrel=1
+pkgdesc='Notifications plug for Switchboard'
+arch=('i686' 'x86_64')
+url='https://launchpad.net/switchboard-plug-applications'
+license=('GPL3')
+groups=('pantheon')
+depends=('glib2' 'glibc' 'gtk3' 'libgee'
+ 'libgranite.so' 'libswitchboard-2.0.so')
+makedepends=('cmake' 'vala')
+source=("https://launchpad.net/switchboard-plug-notifications/freya/${pkgver}/+download/switchboard-plug-notifications-${pkgver}.tar.xz")
+sha256sums=('da5d543492747d9231d3c288324eab9715716c81aa786061c542514725f487ac')
+
+prepare() {
+ cd switchboard-plug-notifications-${pkgver}
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
+}
+
+build() {
+ cd switchboard-plug-notifications-${pkgver}/build
+
+ cmake .. \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_INSTALL_LIBDIR='/usr/lib'
+ make
+}
+
+package() {
+ cd switchboard-plug-notifications-${pkgver}/build
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: