summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122021-06-22 20:01:28 +0200
committerwillemw122021-06-22 20:01:28 +0200
commitf2413f59ea9db51f8820587a42403ad70dea234e (patch)
tree24c35f777af60a761185dad78c7a0812e3a51017
parent07a84e08700253b9638f981a46b14baff91df690 (diff)
downloadaur-f2413f59ea9db51f8820587a42403ad70dea234e.tar.gz
Patch: disable About dialog for builds with granite 6
Update arch, depends, description Change source URL from git:// to git+https:// Change URL to https Minor edits
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
2 files changed, 27 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9019031dbc95..68dffc713199 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = vocal-git
- pkgdesc = Podcast Client for the Modern Desktop
- pkgver = 2.1.5.r239.cab7185
+ pkgdesc = Powerful, beautiful and simple podcast client for Pantheon
+ pkgver = 2.4.2.r415.2cec1f1
pkgrel = 1
- url = http://www.vocalproject.net
- arch = i686
+ url = https://www.vocalproject.net
arch = x86_64
license = GPL3
makedepends = cmake
@@ -11,19 +10,15 @@ pkgbase = vocal-git
makedepends = vala
depends = clutter-gst
depends = clutter-gtk
- depends = desktop-file-utils
depends = granite
- depends = gstreamer
- depends = gtk-update-icon-cache
- depends = gtk3
+ depends = gst-libav
+ depends = gst-plugins-good
+ depends = gvfs
depends = libnotify
- depends = libxml2
- depends = sqlite
depends = webkit2gtk
provides = vocal
conflicts = vocal
- source = vocal::git://github.com/needle-and-thread/vocal.git
+ source = vocal-git::git+https://github.com/needle-and-thread/vocal.git
md5sums = SKIP
pkgname = vocal-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 5e40a7076d9a..05fa50f95678 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,39 +3,44 @@
# Contributor: jus <jus@bitgrid.net>
# Contributor: jfperini <@jfperini>
-_pkgname=vocal
-pkgname=$_pkgname-git
-pkgver=2.1.5.r239.cab7185
+pkgname=vocal-git
+pkgver=2.4.2.r415.2cec1f1
pkgrel=1
-pkgdesc="Podcast Client for the Modern Desktop"
-arch=('i686' 'x86_64')
-url="http://www.vocalproject.net"
+pkgdesc="Powerful, beautiful and simple podcast client for Pantheon"
+arch=('x86_64')
+url="https://www.vocalproject.net"
license=('GPL3')
-depends=('clutter-gst' 'clutter-gtk' 'desktop-file-utils' 'granite' 'gstreamer' 'gtk-update-icon-cache' 'gtk3' 'libnotify' 'libxml2' 'sqlite' 'webkit2gtk')
+depends=('clutter-gst' 'clutter-gtk' 'granite' 'gst-libav' 'gst-plugins-good' 'gvfs' 'libnotify' 'webkit2gtk')
makedepends=('cmake' 'git' 'vala')
-provides=($_pkgname)
-conflicts=($_pkgname)
-source=($_pkgname::git://github.com/needle-and-thread/vocal.git)
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=($pkgname::git+https://github.com/needle-and-thread/vocal.git)
md5sums=('SKIP')
pkgver() {
- cd $_pkgname
+ cd $pkgname
#git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
printf "%s.r%s.%s" "$(git tag --sort=-version:refname | head -1)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-build() {
- cd $_pkgname
+prepare() {
+ cd $pkgname
+
rm -rf build
mkdir build
- cd build
+ # Patch: fix build with granite 6 by disabling the About dialog (https://github.com/needle-and-thread/vocal/issues/483)
+ sed -i 's/controller.app.show_about (this);//' src/MainWindow.vala
+}
+
+build() {
+ cd $pkgname/build
cmake .. -DCMAKE_INSTALL_PREFIX=/usr # -DGSETTINGS_COMPILE=0 -DGSETTINGS_LOCALINSTALL=1
make
}
package() {
- cd $_pkgname/build
+ cd $pkgname/build
make DESTDIR="$pkgdir/" install
}