summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Price2024-02-25 18:56:55 -0800
committerChristopher Price2024-02-25 18:56:55 -0800
commitf24b2079d2470a05256bc84bba0305689caaaade (patch)
tree63d8fcf027621460897649092ede01129ffd3d22
parentef1d7f6c95f201431b0ccd9a99100a8b157058dc (diff)
downloadaur-f24b2079d2470a05256bc84bba0305689caaaade.tar.gz
Updated to latest pre release v0.7.31
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD10
2 files changed, 13 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 37e2b92390b0..daef36c5de04 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,22 @@
pkgbase = google-drive-ocamlfuse
pkgdesc = FUSE-based file system backed by Google Drive, written in OCaml
- pkgver = 0.7.30
- pkgrel = 3
+ pkgver = 0.7.31
+ pkgrel = 1
url = https://astrada.github.io/google-drive-ocamlfuse/
arch = x86_64
license = MIT
- depends = ocaml>=4.04.0
+ makedepends = dune
+ makedepends = ocaml-ounit
+ depends = ocaml>=4.08.0
depends = ocaml-findlib>=1.2.7
depends = ocamlfuse>=2.7.1
- depends = gapi-ocaml>=0.4.2
+ depends = gapi-ocaml>=0.4.5
depends = ocaml-sqlite3>=1.6.1
depends = ocaml-extlib
depends = tiny_httpd>=0.6
- makedepends = dune
- makedepends = ocaml-ounit
options = !strip
options = staticlibs
- source = google-drive-ocamlfuse-0.7.30.tar.gz::https://github.com/astrada/google-drive-ocamlfuse/archive/v0.7.30.tar.gz
- sha256sums = 3fe3f0d4051f1a81e37f6da9e8a492eb3c81f7450c6b43fee81a7fd94249bfa0
+ source = google-drive-ocamlfuse-0.7.31.tar.gz::https://github.com/astrada/google-drive-ocamlfuse/archive/v0.7.31.tar.gz
+ sha256sums = c0a7012f07553b837c74b8373a6a80aa856c20d2fb0432dc464cff3a384e4c9e
pkgname = google-drive-ocamlfuse
-
diff --git a/PKGBUILD b/PKGBUILD
index 5ad1858dd8a7..8a75e80d67d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Christopher Price <pricechrispy at gmail dot com>
# Contributor: Moritz Lipp <mlq@pwmt.org>
pkgname=google-drive-ocamlfuse
-pkgver=0.7.30
-pkgrel=3
+pkgver=0.7.31
+pkgrel=1
pkgdesc='FUSE-based file system backed by Google Drive, written in OCaml'
arch=('x86_64')
url='https://astrada.github.io/google-drive-ocamlfuse/'
license=('MIT')
depends=(
-'ocaml>=4.04.0'
+'ocaml>=4.08.0'
'ocaml-findlib>=1.2.7'
'ocamlfuse>=2.7.1'
-'gapi-ocaml>=0.4.2'
+'gapi-ocaml>=0.4.5'
'ocaml-sqlite3>=1.6.1'
'ocaml-extlib'
'tiny_httpd>=0.6'
@@ -22,7 +22,7 @@ makedepends=(
)
options=('!strip' 'staticlibs')
source=("$pkgname-$pkgver.tar.gz::https://github.com/astrada/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('3fe3f0d4051f1a81e37f6da9e8a492eb3c81f7450c6b43fee81a7fd94249bfa0')
+sha256sums=('c0a7012f07553b837c74b8373a6a80aa856c20d2fb0432dc464cff3a384e4c9e')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"