summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPopolon2021-10-16 14:49:55 +0200
committerPopolon2021-10-16 14:49:55 +0200
commitf24bf388a961d73578ff842df731c8c32d4ae68b (patch)
tree593d7830545bef8b066c504a21762f754d9e321f
downloadaur-f24bf388a961d73578ff842df731c8c32d4ae68b.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0f0d1d5002ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-sphinxcontrib-hdl-diagrams
+ pkgdesc = Generate diagrams from HDL in Sphinx.
+ pkgver = 0.0.post131
+ pkgrel = 1
+ url = https://github.com/SymbiFlow/sphinxcontrib-hdl-diagrams
+ arch = any
+ license = APACHE
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/s/sphinxcontrib-hdl-diagrams/sphinxcontrib-hdl-diagrams-0.0.post131.tar.gz
+ sha256sums = f05f467d91c90b879090ef04f80481cca171d7a8cc909bfa6eef3ed2d6687cf1
+
+pkgname = python-sphinxcontrib-hdl-diagrams
+ depends = python
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1dde30c838f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Popolon <popolon@popolon.org>
+
+pkgbase='python-sphinxcontrib-hdl-diagrams'
+pkgname=('python-sphinxcontrib-hdl-diagrams')
+_module='sphinxcontrib-hdl-diagrams'
+pkgver='0.0.post131'
+pkgrel=1
+pkgdesc="Generate diagrams from HDL in Sphinx."
+url="https://github.com/SymbiFlow/sphinxcontrib-hdl-diagrams"
+depends=('python')
+makedepends=('python-setuptools')
+license=('APACHE')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+sha256sums=('f05f467d91c90b879090ef04f80481cca171d7a8cc909bfa6eef3ed2d6687cf1')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}