summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-09-26 13:39:25 +0200
committerGonçalo Camelo Neves Pereira2018-09-26 13:39:25 +0200
commitf256dcfd8f23e96827adcbde0ddfd4c165a27315 (patch)
treeced605389c0beb974e1c1629d361fd1d6cec7127
parentaed335f06a0713f40cccf192e7bfa3f7b4b3b587 (diff)
downloadaur-f256dcfd8f23e96827adcbde0ddfd4c165a27315.tar.gz
Update
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD135
2 files changed, 78 insertions, 93 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96ce9fc01e46..1403fb53e563 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,33 +7,33 @@ pkgbase = ros-melodic-tf2-ros
license = BSD
makedepends = cmake
makedepends = ros-build-tools
- makedepends = ros-melodic-message-filters
- makedepends = ros-melodic-actionlib-msgs
- makedepends = ros-melodic-tf2-py
makedepends = ros-melodic-rosgraph
+ makedepends = ros-melodic-std-msgs
+ makedepends = ros-melodic-actionlib-msgs
+ makedepends = ros-melodic-roscpp
makedepends = ros-melodic-xmlrpcpp
- makedepends = ros-melodic-geometry-msgs
+ makedepends = ros-melodic-tf2-py
+ makedepends = ros-melodic-tf2-msgs
+ makedepends = ros-melodic-actionlib
+ makedepends = ros-melodic-message-filters
makedepends = ros-melodic-catkin
makedepends = ros-melodic-rospy
- makedepends = ros-melodic-roscpp
- makedepends = ros-melodic-actionlib
- makedepends = ros-melodic-tf2-msgs
makedepends = ros-melodic-tf2
- makedepends = ros-melodic-std-msgs
- depends = ros-melodic-message-filters
- depends = ros-melodic-actionlib-msgs
- depends = ros-melodic-tf2-py
+ makedepends = ros-melodic-geometry-msgs
depends = ros-melodic-rosgraph
- depends = ros-melodic-xmlrpcpp
- depends = ros-melodic-geometry-msgs
- depends = ros-melodic-rospy
+ depends = ros-melodic-std-msgs
+ depends = ros-melodic-actionlib-msgs
depends = ros-melodic-roscpp
- depends = ros-melodic-actionlib
+ depends = ros-melodic-xmlrpcpp
+ depends = ros-melodic-tf2-py
depends = ros-melodic-tf2-msgs
+ depends = ros-melodic-actionlib
+ depends = ros-melodic-message-filters
+ depends = ros-melodic-rospy
depends = ros-melodic-tf2
- depends = ros-melodic-std-msgs
- source = ros-melodic-tf2-ros::git+https://github.com/ros-gbp/geometry2-release.git
- sha256sums = SKIP
+ depends = ros-melodic-geometry-msgs
+ source = ros-melodic-tf2-ros-0.6.3-0.tar.gz::https://github.com/ros-gbp/geometry2-release/archive/release/melodic/tf2_ros/0.6.3-0.tar.gz
+ sha256sums = a92f3b3c050dd41cf658a5f1c0630aa834a888f7f696f25241682319c4ab35b9
pkgname = ros-melodic-tf2-ros
diff --git a/PKGBUILD b/PKGBUILD
index 9f2dab00920f..6678de612c7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Script generated with import_catkin_packages.py.
-# For more information: https://github.com/bchretien/arch-ros-stacks.
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
pkgdesc="ROS - This package contains the ROS bindings for the tf2 library, for both Python and C++."
url='http://www.ros.org/wiki/tf2_ros'
@@ -10,88 +10,73 @@ arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(
- ros-melodic-message-filters
- ros-melodic-actionlib-msgs
- ros-melodic-tf2-py
- ros-melodic-rosgraph
- ros-melodic-xmlrpcpp
- ros-melodic-geometry-msgs
- ros-melodic-catkin
- ros-melodic-rospy
- ros-melodic-roscpp
- ros-melodic-actionlib
- ros-melodic-tf2-msgs
- ros-melodic-tf2
- ros-melodic-std-msgs
-)
+ros_makedepends=(ros-melodic-rosgraph
+ ros-melodic-std-msgs
+ ros-melodic-actionlib-msgs
+ ros-melodic-roscpp
+ ros-melodic-xmlrpcpp
+ ros-melodic-tf2-py
+ ros-melodic-tf2-msgs
+ ros-melodic-actionlib
+ ros-melodic-message-filters
+ ros-melodic-catkin
+ ros-melodic-rospy
+ ros-melodic-tf2
+ ros-melodic-geometry-msgs)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
-makedepends=(
- 'cmake'
- 'ros-build-tools'
- ${ros_makedepends[@]}
-)
+ros_depends=(ros-melodic-rosgraph
+ ros-melodic-std-msgs
+ ros-melodic-actionlib-msgs
+ ros-melodic-roscpp
+ ros-melodic-xmlrpcpp
+ ros-melodic-tf2-py
+ ros-melodic-tf2-msgs
+ ros-melodic-actionlib
+ ros-melodic-message-filters
+ ros-melodic-rospy
+ ros-melodic-tf2
+ ros-melodic-geometry-msgs)
+depends=(${ros_depends[@]})
-ros_depends=(
- ros-melodic-message-filters
- ros-melodic-actionlib-msgs
- ros-melodic-tf2-py
- ros-melodic-rosgraph
- ros-melodic-xmlrpcpp
- ros-melodic-geometry-msgs
- ros-melodic-rospy
- ros-melodic-roscpp
- ros-melodic-actionlib
- ros-melodic-tf2-msgs
- ros-melodic-tf2
- ros-melodic-std-msgs
-)
+# Git version (e.g. for debugging)
+# _tag=release/melodic/tf2_ros/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/geometry2-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
-depends=(
- ${ros_depends[@]}
-)
-
-_dir=${pkgname}
-source=("${_dir}"::"git+https://github.com/ros-gbp/geometry2-release.git")
-sha256sums=('SKIP')
-
-prepare() {
- cd ${srcdir}/${_dir}
- git checkout upstream
- _pkgname=$(echo ${pkgname} | sed 's/ros-lunar-//' | sed 's/-/_/g')
-
- if [ -d ${_pkgname} ]; then
- git subtree split -P ${_pkgname} --branch ${_pkgname}
- git checkout ${_pkgname}
- fi
-}
+# Tarball version (faster download)
+_dir="geometry2-release-release-melodic-tf2_ros-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/geometry2-release/archive/release/melodic/tf2_ros/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('a92f3b3c050dd41cf658a5f1c0630aa834a888f7f696f25241682319c4ab35b9')
build() {
- # Use ROS environment variables.
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
- # Create the build directory.
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
- # Fix Python2/Python3 conflicts.
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
- # Build the project.
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}