summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJochen Jägers2020-05-18 15:12:52 +0200
committerJochen Jägers2020-05-18 15:12:52 +0200
commitf276c637c181888065fde4a2ee6d49e8681cd57f (patch)
treeb6b8bada69287f7ecca0ff130432af7fbe3b0864
parent2af7abc4cdc3795a989694fbb2e125268fb2362a (diff)
downloadaur-f276c637c181888065fde4a2ee6d49e8681cd57f.tar.gz
fixed build problems with gcc10 or without c++11 support
-rw-r--r--.SRCINFO6
-rw-r--r--893.patch21
-rw-r--r--895.patch26
-rw-r--r--PKGBUILD14
4 files changed, 63 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2c192f9998f0..afc48d34ff30 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = websocketpp-git-dev
pkgdesc = C++/Boost Asio based websocket client/server library, Develop branch
pkgver = 0.8.3.1726.52eb086
- pkgrel = 1
+ pkgrel = 2
url = http://www.zaphoyd.com/websocketpp/
arch = any
license = BSD
@@ -18,7 +18,11 @@ pkgbase = websocketpp-git-dev
provides = websocketpp
conflicts = websocketpp
source = websocketpp-git-dev::git+https://github.com/zaphoyd/websocketpp#branch=develop
+ source = 893.patch
+ source = 895.patch
sha512sums = SKIP
+ sha512sums = 2d1e212f2c13358d478997d7573c257f1bfc3c2aa5f52f9cf5a451d718c657e9e3f169433f5e1ef11333398348210385cfb26810e037f45f2be5753ad155095a
+ sha512sums = fa35e00e80c0c9129161df700b0be3a82bf924e074db5ccad45fe3f6a106f7d4dc03acaa6ce37185caad0aece3846e2a07b6f3c58158652277d0c081103f1bbc
pkgname = websocketpp-git-dev
diff --git a/893.patch b/893.patch
new file mode 100644
index 000000000000..5d973b1367a0
--- /dev/null
+++ b/893.patch
@@ -0,0 +1,21 @@
+From 64119d5302b22c7506d46f73b832aed498e2b55b Mon Sep 17 00:00:00 2001
+From: kautsig <cr@kautsig.org>
+Date: Sat, 16 May 2020 12:33:49 +0200
+Subject: [PATCH] Fix copy/paste mistake
+
+---
+ examples/scratch_client/SConscript | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/examples/scratch_client/SConscript b/examples/scratch_client/SConscript
+index 6e7b2ef0..36f0d403 100644
+--- a/examples/scratch_client/SConscript
++++ b/examples/scratch_client/SConscript
+@@ -19,6 +19,6 @@ if env_cpp11.has_key('WSPP_CPP11_ENABLED'):
+ prgs += env_cpp11.Program('scratch_client', ["scratch_client.cpp"], LIBS = ALL_LIBS)
+ else:
+ ALL_LIBS = boostlibs(['system','random'],env) + [platform_libs] + [polyfill_libs]
+- prgs += env.Program('utility_client', ["utility_client.cpp"], LIBS = ALL_LIBS)
++ prgs += env.Program('scratch_client', ["scratch_client.cpp"], LIBS = ALL_LIBS)
+
+ Return('prgs')
diff --git a/895.patch b/895.patch
new file mode 100644
index 000000000000..28f6df3aa9e0
--- /dev/null
+++ b/895.patch
@@ -0,0 +1,26 @@
+From e0f139db37b3ad7597900b0e98b14b832b00c4a9 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Jochen=20J=C3=A4gers?= <jochen.jaegers@riedel-at.de>
+Date: Mon, 18 May 2020 14:50:29 +0200
+Subject: [PATCH] fix gcc version detection
+
+---
+ SConstruct | 6 ++----
+ 1 file changed, 2 insertions(+), 4 deletions(-)
+
+diff --git a/SConstruct b/SConstruct
+index c5ae1936..5150de94 100644
+--- a/SConstruct
++++ b/SConstruct
+@@ -158,10 +158,8 @@ polyfill_libs = [] # boost libraries used as drop in replacements for incomplete
+ env_cpp11 = env.Clone ()
+
+ if env_cpp11['CXX'].startswith('g++'):
+- # TODO: check g++ version
+- GCC_VERSION = check_output([env_cpp11['CXX'], '-dumpversion']).decode("utf-8")
+-
+- if GCC_VERSION > "4.4.0":
++ GCC_VERSION = check_output([env_cpp11['CXX'], '-dumpversion']).decode("utf-8").strip().split(".")
++ if int(GCC_VERSION[0]) > 4 or (int(GCC_VERSION[0]) == 4 and int(GCC_VERSION[1]) > 4):
+ print("C++11 build environment partially enabled")
+ env_cpp11.Append(WSPP_CPP11_ENABLED = "true",CXXFLAGS = ['-std=c++0x'],TOOLSET = ['g++'],CPPDEFINES = ['_WEBSOCKETPP_CPP11_STL_'])
+ else:
diff --git a/PKGBUILD b/PKGBUILD
index e908dcb3b376..9af7935d498e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=websocketpp-git-dev
_gitname=websocketpp
pkgver=0.8.3.1726.52eb086
-pkgrel=1
+pkgrel=2
pkgdesc='C++/Boost Asio based websocket client/server library, Develop branch'
url='http://www.zaphoyd.com/websocketpp/'
arch=('any')
@@ -18,8 +18,10 @@ optdepends=(
makedepends=('git' 'cmake' 'boost' 'boost-libs' 'scons' 'gawk')
provides=('websocketpp')
conflicts=('websocketpp')
-source=(${pkgname}::git+https://github.com/zaphoyd/${_gitname}#branch=develop)
-sha512sums=('SKIP')
+source=(${pkgname}::git+https://github.com/zaphoyd/${_gitname}#branch=develop 893.patch 895.patch)
+sha512sums=('SKIP'
+ '2d1e212f2c13358d478997d7573c257f1bfc3c2aa5f52f9cf5a451d718c657e9e3f169433f5e1ef11333398348210385cfb26810e037f45f2be5753ad155095a'
+ 'fa35e00e80c0c9129161df700b0be3a82bf924e074db5ccad45fe3f6a106f7d4dc03acaa6ce37185caad0aece3846e2a07b6f3c58158652277d0c081103f1bbc' )
pkgver() {
cd ${pkgname}
@@ -31,6 +33,12 @@ pkgver() {
"$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd ${pkgname}
+ patch --forward --strip=1 --input="${srcdir}/893.patch"
+ patch --forward --strip=1 --input="${srcdir}/895.patch"
+}
+
build() {
cd ${pkgname}
WSPP_ENABLE_CPP11=1 \