summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorA.I2020-12-21 18:08:23 +0800
committerA.I2020-12-21 18:08:23 +0800
commitf2a2ff261641f2dfe54df8dcf1f5cc995f7b26c1 (patch)
tree2d70f683ab3065481ead2a8c1776629de44d07ae
parentcc80074f89b5b9e9ef3bfb1041fa270e6b4ecaa4 (diff)
downloadaur-f2a2ff261641f2dfe54df8dcf1f5cc995f7b26c1.tar.gz
updates glow-sans-sc-compressed to v0.92
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--update.sh37
3 files changed, 42 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5f726dab6c4..1d174913aa69 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = glow-sans-sc-compressed
pkgdesc = SHSans-derived CJK font family with a more concise & modern look.
- pkgver = v0.91
+ pkgver = v0.92
pkgrel = 1
url = https://welai.github.io/glow-sans
arch = any
license = MIT
- source = https://github.com/welai/glow-sans/releases/download/v0.91/GlowSansSC-Compressed-v0.91.zip
- md5sums = 4eb6417cb208171d8f51835ae1c76c6b
+ source = https://github.com/welai/glow-sans/releases/download/v0.92/GlowSansSC-Compressed-v0.92.zip
+ md5sums = 0ea6e9d7f8dbad1476a749b519061f0f
pkgname = glow-sans-sc-compressed
diff --git a/PKGBUILD b/PKGBUILD
index aab9c1c1c60a..5e19155049ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
_script=sc
_width=compressed
pkgname=glow-sans-${_script}-${_width}
-pkgver=v0.91
+pkgver=v0.92
pkgrel=1
pkgdesc="SHSans-derived CJK font family with a more concise & modern look."
url="https://welai.github.io/glow-sans"
arch=(any)
license=(MIT)
source=(https://github.com/welai/glow-sans/releases/download/$pkgver/GlowSans${_script^^}-${_width^}-$pkgver.zip)
-md5sums=('4eb6417cb208171d8f51835ae1c76c6b')
+md5sums=('0ea6e9d7f8dbad1476a749b519061f0f')
package() {
install -Dt "$pkgdir/usr/share/fonts/${pkgname%-fonts}" -m644 $srcdir/*.otf
diff --git a/update.sh b/update.sh
new file mode 100644
index 000000000000..8a190bf802eb
--- /dev/null
+++ b/update.sh
@@ -0,0 +1,37 @@
+#!/usr/bin/env bash
+set -euo pipefail
+
+set -x
+
+scripts=(sc tc j)
+widths=(compressed condensed extended normal wide)
+
+if [ $# -ne 1 ]; then
+ echo "usage: update.sh v0.91"
+ exit 1
+fi
+
+new_version=$1
+
+for script in "${scripts[@]}"
+do
+ for width in "${widths[@]}"
+ do
+ pkgname="glow-sans-${script}-${width}"
+ echo "updating ${pkgname} to ${new_version}."
+
+ # switching branch and remote
+ git remote set-url aur "ssh://aur@aur.archlinux.org/$pkgname"
+ git fetch aur master
+ git checkout -B ${pkgname} aur/master
+
+ # update version
+ sed -i "s/pkgver=.*$/pkgver=${new_version}/" PKGBUILD
+ updpkgsums
+ makepkg --printsrcinfo > .SRCINFO
+ git add .
+ git commit -m "updates ${pkgname} to ${new_version}"
+ git push aur ${pkgname}:master
+ echo "updated ${pkgname} to ${new_version}."
+ done
+done