summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Chesters2018-06-14 20:59:12 +0200
committerDaniel Chesters2018-06-14 20:59:12 +0200
commitf2f50f7ac1331597882df8e9be8867998c1607d3 (patch)
treee4be642c4213cad41a5776329cca8652dec1e16e
downloadaur-f2f50f7ac1331597882df8e9be8867998c1607d3.tar.gz
Add PKGBUILD (and .SRCINFO, and .gitignore)
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5788019e57d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = i3wsr-git
+ pkgdesc = A small program to change the name of an i3 workspace based on its contents.
+ pkgver = 1.1.0.r0.gcc59043
+ pkgrel = 1
+ url = https://github.com/roosta/i3wsr
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = cargo
+ makedepends = git
+ depends = i3-wm
+ provides = i3wsr
+ conflicts = i3wsr
+ source = i3wsr-git::git+https://github.com/roosta/i3wsr.git
+ md5sums = SKIP
+
+pkgname = i3wsr-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..75a96a7ab233
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.tar.*
+i3wsr-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f09265c99d91
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer : Daniel Chesters <daniel.chesters@gmail.com>
+
+pkgname=i3wsr-git
+pkgver=1.1.0.r0.gcc59043
+pkgrel=1
+pkgdesc="A small program to change the name of an i3 workspace based on its contents."
+url="https://github.com/roosta/i3wsr"
+depends=('i3-wm')
+makedepends=('cargo' 'git')
+arch=('i686' 'x86_64')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+license=('MIT')
+source=("$pkgname::git+https://github.com/roosta/i3wsr.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$pkgname"
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm755 "target/release/${pkgname%-git}" "$pkgdir/usr/bin/${pkgname%-git}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: