summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBakasura2022-12-13 21:33:21 -0500
committerBakasura2022-12-13 21:33:21 -0500
commitf3128ac617a0fb230cd93d9011f73ef4d077079b (patch)
tree1028d9309ed587fc8b50c4084c5ccd38203b0093
parent169a464195530915e4abee850a1bf4b5d86590d5 (diff)
downloadaur-f3128ac617a0fb230cd93d9011f73ef4d077079b.tar.gz
fix: change svn repo
feat: use parallel make
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD10
-rw-r--r--disable-debian.patch11
4 files changed, 8 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4bd056b633c9..efb234f19972 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cbftp-svn
pkgdesc = an advanced multi-purpose FTP/FXP client that focuses on efficient large-scale data spreading, while also supporting most regular FTP/FXP use cases in a modern way. It runs in a terminal and provides a semi-graphical user interface through ncurses.
- pkgver = r1183
+ pkgver = r1236
pkgrel = 1
url = https://cbftp.eu
arch = x86_64
@@ -13,9 +13,7 @@ pkgbase = cbftp-svn
provides = cbftp-svn
conflicts = cbftp
replaces = cbftp
- source = svn+https://cbftp.eu/svn/cbftp/
- source = disable-debian.patch
+ source = svn+https://cbftp.gay/svn/cbftp/
sha256sums = SKIP
- sha256sums = 77bbedb52617cc34edc49e6d93075c092b333fdb17c4b554f431e7057a90fcd8
pkgname = cbftp-svn
diff --git a/.gitignore b/.gitignore
index 93a31e327aac..cc52edb3940a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,4 +3,5 @@
*.log
pkg/
src/
-cbftp/ \ No newline at end of file
+cbftp/
+.idea \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 69ba072914f7..7f23e32c3ecf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Bakasura <bakasura@protonmail.ch>
pkgname=cbftp-svn
-pkgver=r1183
+pkgver=r1236
pkgrel=1
pkgdesc='an advanced multi-purpose FTP/FXP client that focuses on efficient large-scale data spreading, while also supporting most regular FTP/FXP use cases in a modern way. It runs in a terminal and provides a semi-graphical user interface through ncurses.'
arch=('x86_64')
@@ -14,9 +14,8 @@ conflicts=('cbftp')
replaces=('cbftp')
license=('MIT')
_srcname=cbftp
-source=("svn+https://cbftp.eu/svn/cbftp/" "disable-debian.patch")
-sha256sums=('SKIP'
- '77bbedb52617cc34edc49e6d93075c092b333fdb17c4b554f431e7057a90fcd8')
+source=("svn+https://cbftp.gay/svn/cbftp/")
+sha256sums=('SKIP')
pkgver() {
cd "$_srcname"
@@ -26,12 +25,11 @@ pkgver() {
build() {
cd "$_srcname"
- make
+ make -j
}
prepare() {
cd "$_srcname"
- patch -Np0 -i "${srcdir}/disable-debian.patch"
}
package() {
diff --git a/disable-debian.patch b/disable-debian.patch
deleted file mode 100644
index 518f2835a5b1..000000000000
--- a/disable-debian.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/ui/ncurseswrap.h 2021-12-23 14:30:57.292928343 -0500
-+++ src/ui/ncurseswrap.h 2021-12-23 14:35:43.500147277 -0500
-@@ -2,7 +2,7 @@
- #define _XOPEN_SOURCE_EXTENDED
- #endif
- #ifndef NO_NCURSESW
--#include <ncursesw/curses.h>
-+#include <ncurses.h>
- #else
- #include <ncurses.h>
- #endif