summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2016-03-27 12:13:56 +0200
committerChristopher Arndt2016-03-27 12:13:56 +0200
commitf3325c9b3547afd4fb94f9f67de213b7aeb46944 (patch)
tree5fd75342a76840bb9a6a6b97f12d186bd6940668
downloadaur-f3325c9b3547afd4fb94f9f67de213b7aeb46944.tar.gz
Add new package 'audiotk-git'
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD63
-rw-r--r--audiotk-git_h.patch12
4 files changed, 105 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c592a90bacdc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Sun Mar 27 07:33:20 UTC 2016
+pkgbase = audiotk-git
+ pkgdesc = A C++ library with a set of audio filters (git version)
+ pkgver = 1.1.0.r803.12b0a3a
+ pkgrel = 1
+ url = https://github.com/mbrucher/AudioTK
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = cmake
+ depends = fftw
+ depends = libsndfile
+ depends = python
+ provides = audiotk
+ conflicts = audiotk
+ source = audiotk::git+https://github.com/mbrucher/AudioTK.git
+ source = audiotk-git_h.patch
+ md5sums = SKIP
+ md5sums = bfb36a2eb0f771271cdd96bc9217a777
+
+pkgname = audiotk-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b25b52109e48
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg/
+src/
+.AURINFO
+audiotk/
+audiotk-git-*.tar.xz
+audiotk-git-*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3550729cd1ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+_pkgname=audiotk
+pkgname="${_pkgname}-git"
+pkgver=1.1.0.r803.12b0a3a
+pkgrel=1
+pkgdesc="A C++ library with a set of audio filters (git version)"
+arch=('i686' 'x86_64')
+license=('BSD')
+url='https://github.com/mbrucher/AudioTK'
+depends=('fftw' 'libsndfile' 'python')
+makedepends=('git' 'cmake')
+source=("${_pkgname}::git+https://github.com/mbrucher/AudioTK.git"
+ 'audiotk-git_h.patch')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+md5sums=('SKIP'
+ 'bfb36a2eb0f771271cdd96bc9217a777')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ version="$(git describe --tags | sed -e 's/^[^-]*-//;s/-.*//')"
+ revision=$(git rev-list --count HEAD)
+ hash=$(git rev-parse --short HEAD)
+ echo $version.r$revision.$hash
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+
+ mkdir build
+ git checkout develop
+
+ patch -p1 -r - -i "${srcdir}/audiotk-git_h.patch"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}/build"
+
+ local py_ver=$(python -c 'import sys; print("%s.%s" % sys.version_info[:2])')
+ cmake .. \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_CXX_FLAGS="-std=c++11" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DENABLE_PYTHON=1 \
+ -DPYTHON_INSTALL_FOLDER=/usr/lib/python${py_ver} \
+ -DENABLE_TESTS=1
+ make DESTDIR="${pkgdir}"
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}/build"
+
+ make DESTDIR="${pkgdir}" install
+
+ install -Dm644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/audiotk-git_h.patch b/audiotk-git_h.patch
new file mode 100644
index 000000000000..edb333440e7b
--- /dev/null
+++ b/audiotk-git_h.patch
@@ -0,0 +1,12 @@
+diff --git a/tests/Distortion/SimpleOverdriveFilter.cpp b/tests/Distortion/SimpleOverdriveFilter.cpp
+index 61f16cd..24f1397 100644
+--- a/tests/Distortion/SimpleOverdriveFilter.cpp
++++ b/tests/Distortion/SimpleOverdriveFilter.cpp
+@@ -3,7 +3,6 @@
+ */
+
+ #include <ATK/config.h>
+-#include <ATK/git.h>
+
+ #include <ATK/Distortion/SimpleOverdriveFilter.h>
+