summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpingplug2020-10-22 20:33:30 +0800
committerpingplug2020-10-22 20:33:30 +0800
commitf3556039844077f74e311e43a4eace1bd125bf60 (patch)
tree60f1bc8e291342945e11cfa5de0bcaf21779b361
parent575be89027a94bf3784c5483fbb6e3226e070455 (diff)
downloadaur-f3556039844077f74e311e43a4eace1bd125bf60.tar.gz
fix depends again
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5fda08404f79..c70a173b9c3f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = mingw-w64-readline
pkgdesc = GNU readline library (mingw-w64)
pkgver = 8.0.004
- pkgrel = 1
+ pkgrel = 2
url = https://tiswww.case.edu/php/chet/readline/rltop.html
arch = any
license = GPL
makedepends = mingw-w64-configure
depends = mingw-w64-crt
depends = mingw-w64-pdcurses
+ depends = mingw-w64-termcap
options = !strip
options = staticlibs
options = !buildflags
diff --git a/PKGBUILD b/PKGBUILD
index da86ea947f48..94cc0febafb3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,13 +9,14 @@ _architectures="i686-w64-mingw32 x86_64-w64-mingw32"
pkgname=mingw-w64-readline
pkgver=${_basever}.${_patchlevel}
-pkgrel=1
+pkgrel=2
pkgdesc="GNU readline library (mingw-w64)"
arch=('any')
url="https://tiswww.case.edu/php/chet/readline/rltop.html"
license=('GPL')
depends=('mingw-w64-crt'
- 'mingw-w64-pdcurses')
+ 'mingw-w64-pdcurses'
+ 'mingw-w64-termcap')
makedepends=('mingw-w64-configure')
options=('!strip' 'staticlibs' '!buildflags')
source=("https://ftp.gnu.org/gnu/readline/readline-${_basever}.tar.gz"{,.sig})
@@ -59,7 +60,7 @@ build() {
--enable-multibyte \
--without-purify \
--with-curses
- make SHLIB_LIBS="-lpdcurses"
+ make SHLIB_LIBS="-lpdcurses -ltermcap"
popd
done
}
@@ -67,7 +68,7 @@ build() {
package() {
for _arch in ${_architectures} ; do
cd "${srcdir}/readline-${_basever}/build-${_arch}"
- make install DESTDIR="${pkgdir}" SHLIB_LIBS="-lpdcurses"
+ make install DESTDIR="${pkgdir}" SHLIB_LIBS="-lpdcurses -ltermcap"
rm -r "${pkgdir}"/usr/${_arch}/share/
${_arch}-strip --strip-unneeded "${pkgdir}"/usr/${_arch}/bin/*.dll
${_arch}-strip --strip-debug "${pkgdir}"/usr/${_arch}/lib/*.a