summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2020-04-03 22:22:23 +0200
committerNarrat2020-04-03 22:22:23 +0200
commitf374002be0339b4e933e36786d20b8d20f761e5d (patch)
treeada7405b6c5aeebca81f9646516456594289fd67
parentd92f77134d4914388ba42d516d92914f9a4e4041 (diff)
downloadaur-f374002be0339b4e933e36786d20b8d20f761e5d.tar.gz
update patches
Shellscript got deprecated, so there is a need to look for changes in deps and such
-rw-r--r--.SRCINFO8
-rw-r--r--01_openssl102.patch5
-rw-r--r--02_freetype.patch5
-rw-r--r--PKGBUILD4
4 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c8c4a2e7864a..9a12303b4c72 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,14 +15,14 @@ pkgbase = tibia
depends = pcre
depends = qt5-base
depends = qt5-declarative
- source = tibia.tar.gz::http://static.tibia.com/download/tibia.x64.tar.gz
- source = tibia-agreement.php::http://www.tibia.com/support/agreement.php
+ source = tibia.tar.gz::https://static.tibia.com/download/tibia.x64.tar.gz
+ source = tibia-agreement.php::https://www.tibia.com/support/agreement.php
source = 01_openssl102.patch
source = 02_freetype.patch
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = e9e6cdd4e2954ae0838dc427a92871bb9cacdacb0523598c60287a05f8568d1f
- sha256sums = 3cdf107369e4366aa5fc6d1b90ba0b41bd3d19abeb418fb85a693d74c3ece736
+ sha256sums = f3a7c01c0664155a82f00a3d84d6d4a01f7786e872f3a12ae89886542bc43482
+ sha256sums = 55d87bd8f32728cd47757a195102e2af2d10a1501d9370af86606b2c75211515
pkgname = tibia
diff --git a/01_openssl102.patch b/01_openssl102.patch
index 8be99280af5e..13a9b714a51a 100644
--- a/01_openssl102.patch
+++ b/01_openssl102.patch
@@ -1,9 +1,8 @@
--- start-tibia-launcher.sh
+++ start-tibia-launcher.sh
-@@ -7,4 +7,4 @@
+@@ -5,4 +5,4 @@
SCRIPT=$(readlink -f "$0")
PATH=$(dirname "$SCRIPT")
--LD_LIBRARY_PATH="$PATH" exec "$PATH/Tibia"
+-exec "$PATH/Tibia"
+LD_LIBRARY_PATH="$PATH:/usr/lib/openssl-1.0/" exec "$PATH/Tibia"
-
diff --git a/02_freetype.patch b/02_freetype.patch
index d14d4424927d..42580d1b00c0 100644
--- a/02_freetype.patch
+++ b/02_freetype.patch
@@ -1,10 +1,9 @@
--- start-tibia-launcher.sh
+++ start-tibia-launcher.sh
-@@ -6,5 +6,6 @@
+@@ -4,5 +4,6 @@
SCRIPT=$(readlink -f "$0")
PATH=$(dirname "$SCRIPT")
+export FREETYPE_PROPERTIES="truetype:interpreter-version=38"
- LD_LIBRARY_PATH="$PATH" exec "$PATH/client"
-
+ LD_LIBRARY_PATH="$PATH:/usr/lib/openssl-1.0/" exec "$PATH/Tibia"
diff --git a/PKGBUILD b/PKGBUILD
index 96354c2470f0..6d6217348f69 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,8 +20,8 @@ source=("${pkgname}.tar.gz::https://static.tibia.com/download/tibia.x64.tar.gz"
sha256sums=('SKIP'
'SKIP'
- 'e9e6cdd4e2954ae0838dc427a92871bb9cacdacb0523598c60287a05f8568d1f'
- '3cdf107369e4366aa5fc6d1b90ba0b41bd3d19abeb418fb85a693d74c3ece736')
+ 'f3a7c01c0664155a82f00a3d84d6d4a01f7786e872f3a12ae89886542bc43482'
+ '55d87bd8f32728cd47757a195102e2af2d10a1501d9370af86606b2c75211515')
prepare() {
gendesk -f -n