summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-07-13 12:29:59 +0300
committerDimitris Kiziridis2020-07-13 12:29:59 +0300
commitf3dc33e5408f9c449b6d6dbd10cb9f0ed26ff4fa (patch)
treef40f4e93262d292282730d7d5751ee64aa04ef9e
downloadaur-f3dc33e5408f9c449b6d6dbd10cb9f0ed26ff4fa.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..43b394ec0a4b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = bookscanwizard
+ pkgdesc = A utility to help with Book scanning using cameras as a scanner. It will automate things such as cropping, rotating, fixing keystoning, fixing the DPI, and outputing it to tiff files that can be changed into PDF's or ebooks
+ pkgver = 2.0.2c
+ pkgrel = 1
+ url = https://sourceforge.net/projects/bookscanwizard
+ arch = any
+ license = GPL2
+ makedepends = gendesk
+ depends = java-environment>=7
+ depends = bash
+ source = bookscanwizard-2.0.2c.zip::https://sourceforge.net/projects/bookscanwizard/files/BookScanWizard_2.0.2c.zip/download
+ sha256sums = cfef50b1ed5601c6ec4041623a634b8a283fca4f5414a2353fdbef943852427a
+
+pkgname = bookscanwizard
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..234338785d96
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=bookscanwizard
+pkgver=2.0.2c
+pkgrel=1
+pkgdesc="A utility to help with Book scanning using cameras as a scanner. It will automate things such as cropping, rotating, fixing keystoning, fixing the DPI, and outputing it to tiff files that can be changed into PDF's or ebooks"
+arch=('any')
+url="https://sourceforge.net/projects/bookscanwizard"
+license=('GPL2')
+depends=('java-environment>=7' 'bash')
+makedepends=('gendesk')
+source=("${pkgname}-${pkgver}.zip::https://sourceforge.net/projects/bookscanwizard/files/BookScanWizard_${pkgver}.zip/download")
+sha256sums=('cfef50b1ed5601c6ec4041623a634b8a283fca4f5414a2353fdbef943852427a')
+
+package() {
+ install -Dm644 BookScanWizard.jar -t "${pkgdir}/usr/share/java/${pkgname}"
+ cp -aR lib "${pkgdir}/usr/share/java/${pkgname}"
+ install -Dm644 bsw.png -t "${pkgdir}/usr/share/pixmaps/"
+ echo "#!/usr/bin/env bash
+ java -Xmx8192M -jar /usr/share/java/${pkgname}/BookScanWizard.jar" > bsw.sh
+ install -Dm755 bsw.sh "${pkgdir}/usr/bin/bsw"
+ gendesk -f -n --pkgname bsw \
+ --pkgdesc "$pkgdesc" \
+ --name "Book Scan Wizard" \
+ --comment "$pkgdesc" \
+ --exec bsw \
+ --categories 'Utility;Application;' \
+ --icon bsw
+ install -Dm644 bsw.desktop -t "${pkgdir}/usr/share/applications"
+} \ No newline at end of file