summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQue Quotion2017-03-05 00:04:03 +0900
committerQue Quotion2017-03-05 00:04:03 +0900
commitf3fbe2fd25541e0857f5aa414fa661fdf68d5e74 (patch)
tree93af8ecea8eb5013992ddb7310574cfcc9198c6a
downloadaur-f3fbe2fd25541e0857f5aa414fa661fdf68d5e74.tar.gz
wingpanel-standalone-bzr: wingpanel without gala dependency
-rw-r--r--.SRCINFO40
-rw-r--r--PKGBUILD65
-rw-r--r--disable-expanded.patch11
-rw-r--r--minus-backgroundmanager.patch73
-rw-r--r--minus-galaplugin.patch150
-rw-r--r--wingpanel.install14
6 files changed, 353 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..116dfd68ba25
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,40 @@
+# Generated by mksrcinfo v8
+# Sat Mar 4 14:59:26 UTC 2017
+pkgbase = wingpanel-standalone-bzr
+ pkgdesc = The Pantheon Panel (without Gala dependencies)
+ pkgver = r172
+ pkgrel = 1
+ epoch = 1
+ url = https://launchpad.net/wingpanel
+ install = wingpanel.install
+ arch = i686
+ arch = x86_64
+ groups = pantheon-unstable
+ license = GPL3
+ makedepends = bzr
+ makedepends = cmake
+ makedepends = vala
+ depends = clutter
+ depends = cogl
+ depends = glib2
+ depends = glibc
+ depends = gtk3
+ depends = libgee
+ depends = mutter
+ depends = libgranite.so
+ provides = wingpanel
+ provides = wingpanel-bzr
+ provides = libwingpanel-2.0.so
+ conflicts = wingpanel
+ conflicts = wingpanel-bzr
+ source = wingpanel::bzr+lp:wingpanel
+ source = minus-backgroundmanager.patch
+ source = minus-galaplugin.patch
+ source = disable-expanded.patch
+ sha256sums = SKIP
+ sha256sums = 0fd440cdb4b9871c5ee8812866b365e4a45b29813800345556db74429bacca3e
+ sha256sums = 1f50f34a7d36fc8331c1080c42c38f8208e35f4551eed97705919d304d410c95
+ sha256sums = 383e96233c95335d2ef4390e15c7c3cff1c146b6736390e90e96e5e59ea43f3e
+
+pkgname = wingpanel-standalone-bzr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b8c1b0789af3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Ner0 <darkelfdarkelf666@yahoo.co.uk>
+# Contributor: flamelab <panosfilip@gmail.com>
+
+pkgname=wingpanel-standalone-bzr
+pkgver=r172
+pkgrel=1
+epoch=1
+pkgdesc='The Pantheon Panel (without Gala dependencies)'
+arch=('i686' 'x86_64')
+url='https://launchpad.net/wingpanel'
+license=('GPL3')
+groups=('pantheon-unstable')
+depends=('clutter' 'cogl' 'glib2' 'glibc' 'gtk3' 'libgee' 'mutter'
+ 'libgranite.so')
+makedepends=('bzr' 'cmake' 'vala')
+provides=(wingpanel{,-bzr} 'libwingpanel-2.0.so')
+conflicts=(wingpanel{,-bzr})
+install='wingpanel.install'
+source=('wingpanel::bzr+lp:wingpanel'
+ 'minus-backgroundmanager.patch'
+ 'minus-galaplugin.patch'
+ 'disable-expanded.patch')
+sha256sums=('SKIP'
+ '0fd440cdb4b9871c5ee8812866b365e4a45b29813800345556db74429bacca3e'
+ '1f50f34a7d36fc8331c1080c42c38f8208e35f4551eed97705919d304d410c95'
+ '383e96233c95335d2ef4390e15c7c3cff1c146b6736390e90e96e5e59ea43f3e')
+
+pkgver() {
+ cd wingpanel
+
+ echo "r$(bzr revno)"
+}
+
+prepare() {
+ cd wingpanel
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
+
+ #Standalone patches
+ patch -Np2 < ../minus-backgroundmanager.patch
+ patch -Np2 < ../minus-galaplugin.patch
+ patch -Np2 < ../disable-expanded.patch
+}
+
+build() {
+ cd wingpanel/build
+
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_INSTALL_LIBDIR='/usr/lib' \
+ -DGSETTINGS_COMPILE='FALSE'
+ make
+}
+
+package() {
+ cd wingpanel/build
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/disable-expanded.patch b/disable-expanded.patch
new file mode 100644
index 000000000000..be0d6b869165
--- /dev/null
+++ b/disable-expanded.patch
@@ -0,0 +1,11 @@
+--- src/wingpanel/src/Services/PopoverManager.vala 2016-11-15 07:39:04.620620000 +0900
++++ src/wingpanel/src/Services/PopoverManager.vala.new 2017-03-04 23:28:24.941257149 +0900
+@@ -187,7 +187,7 @@
+ });
+
+ widg.enter_notify_event.connect ((w, e) => {
+- owner.set_expanded (true);
++ //owner.set_expanded (true);
+
+ if (mousing) {
+ return Gdk.EVENT_PROPAGATE;
diff --git a/minus-backgroundmanager.patch b/minus-backgroundmanager.patch
new file mode 100644
index 000000000000..25a150955e53
--- /dev/null
+++ b/minus-backgroundmanager.patch
@@ -0,0 +1,73 @@
+--- src/wingpanel/src/PanelWindow.vala 2016-10-21 23:51:49.434036000 +0900
++++ src/wingpanel/src/PanelWindow.vala.new 2016-10-22 00:21:00.991151961 +0900
+@@ -86,7 +86,7 @@
+ private void on_realize () {
+ update_panel_dimensions ();
+
+- Services.BackgroundManager.get_default ().initialize (this.monitor_number, panel_height);
++ //Services.BackgroundManager.get_default ().initialize (this.monitor_number, panel_height);
+
+ Timeout.add (300 / panel_height, animation_step);
+ }
+@@ -152,7 +152,7 @@
+
+ public void set_expanded (bool expanded) {
+ if (expand && !this.expanded) {
+- Services.BackgroundManager.get_default ().remember_window ();
++ //Services.BackgroundManager.get_default ().remember_window ();
+
+ this.expanded = true;
+
+@@ -163,7 +163,7 @@
+
+ this.set_size_request (monitor_width, monitor_height);
+ } else if (!expand) {
+- Services.BackgroundManager.get_default ().restore_window ();
++ //Services.BackgroundManager.get_default ().restore_window ();
+
+ this.expanded = false;
+
+--- src/wingpanel/src/Widgets/Panel.vala 2016-10-22 00:14:45.485792472 +0900
++++ src/wingpanel/src/Widgets/Panel.vala.new 2016-10-22 00:15:13.386112571 +0900
+@@ -60,7 +60,7 @@
+
+ style_context = this.get_style_context ();
+
+- Services.BackgroundManager.get_default ().background_state_changed.connect (update_background);
++ //Services.BackgroundManager.get_default ().background_state_changed.connect (update_background);
+ }
+
+ private void add_indicator (Indicator indicator) {
+@@ -102,7 +102,7 @@
+ }
+ }
+
+- private void update_background (Services.BackgroundState state, uint animation_duration) {
++ /* private void update_background (Services.BackgroundState state, uint animation_duration) {
+ if (style_provider == null) {
+ style_provider = new Gtk.CssProvider ();
+ style_context.add_provider (style_provider, Gtk.STYLE_PROVIDER_PRIORITY_APPLICATION);
+@@ -146,5 +146,5 @@
+ style_context.remove_class ("maximized");
+ break;
+ }
+- }
++ } */
+ }
+--- src/wingpanel/src/Services/BackgroundManager.vala 2016-10-21 23:51:49.434036000 +0900
++++ src/wingpanel/src/Services/BackgroundManager.vala.new 2016-10-22 00:05:37.809131283 +0900
+@@ -17,7 +17,7 @@
+ * Boston, MA 02111-1307, USA.
+ */
+
+-namespace Wingpanel.Services {
++/* namespace Wingpanel.Services {
+ public enum BackgroundState {
+ LIGHT,
+ DARK,
+@@ -114,4 +114,4 @@
+ return instance;
+ }
+ }
+-}
++} */
diff --git a/minus-galaplugin.patch b/minus-galaplugin.patch
new file mode 100644
index 000000000000..a3bca265d032
--- /dev/null
+++ b/minus-galaplugin.patch
@@ -0,0 +1,150 @@
+--- src/wingpanel/wingpanel-interface/BackgroundManager.vala 2016-10-21 23:51:49.434036000 +0900
++++ src/wingpanel/wingpanel-interface/BackgroundManager.vala.new 2016-10-22 00:31:35.323418157 +0900
+@@ -17,7 +17,7 @@
+ * Boston, MA 02111-1307, USA.
+ */
+
+-public enum BackgroundState {
++/* public enum BackgroundState {
+ LIGHT,
+ DARK,
+ MAXIMIZED,
+@@ -152,7 +152,7 @@
+ * - If the background is too bright, it should be DARK;
+ * - Else it should be LIGHT.
+ */
+- private void check_for_state_change (uint animation_duration) {
++ /*private void check_for_state_change (uint animation_duration) {
+ bool has_maximized_window = false;
+
+ foreach (Meta.Window window in current_workspace.list_windows ()) {
+@@ -184,4 +184,4 @@
+ state_changed (current_state = new_state, animation_duration);
+ }
+ }
+-}
++} */
+--- src/wingpanel/wingpanel-interface/DBusServer.vala 2016-10-22 00:31:41.667214839 +0900
++++ src/wingpanel/wingpanel-interface/DBusServer.vala.new 2016-10-22 00:31:51.473900535 +0900
+@@ -17,7 +17,7 @@
+ * Boston, MA 02111-1307, USA.
+ */
+
+-[DBus (name = "org.pantheon.gala.WingpanelInterface")]
++/* [DBus (name = "org.pantheon.gala.WingpanelInterface")]
+ public class WingpanelInterface.DBusServer : Object {
+ private BackgroundManager background_manager;
+
+@@ -37,4 +37,4 @@
+ public void restore_focused_window () {
+ FocusManager.get_default ().restore_focused_window ();
+ }
+-}
++} */
+--- src/wingpanel/wingpanel-interface/FocusManager.vala 2016-10-21 23:51:49.434036000 +0900
++++ src/wingpanel/wingpanel-interface/FocusManager.vala.new 2016-10-22 00:32:26.189787894 +0900
+@@ -17,7 +17,7 @@
+ * Boston, MA 02111-1307, USA.
+ */
+
+-public class WingpanelInterface.FocusManager : Object {
++/* public class WingpanelInterface.FocusManager : Object {
+ private static FocusManager? instance = null;
+
+ private Meta.Workspace? current_workspace = null;
+@@ -69,4 +69,4 @@
+
+ return instance;
+ }
+-}
+\ No newline at end of file
++} */
+--- src/wingpanel/wingpanel-interface/Main.vala 2016-10-21 23:51:49.434036000 +0900
++++ src/wingpanel/wingpanel-interface/Main.vala.new 2016-10-22 00:33:13.987255987 +0900
+@@ -22,7 +22,7 @@
+ * about windows and workspaces for the panel.
+ */
+
+-public class WingpanelInterface.Main : Gala.Plugin {
++/* public class WingpanelInterface.Main : Gala.Plugin {
+ private const string DBUS_NAME = "org.pantheon.gala.WingpanelInterface";
+ private const string DBUS_PATH = "/org/pantheon/gala/WingpanelInterface";
+
+@@ -80,4 +80,4 @@
+ Gala.PluginFunction.ADDITION,
+ Gala.LoadPriority.IMMEDIATE
+ };
+-}
+\ No newline at end of file
++} */
+--- src/wingpanel/wingpanel-interface/Settings.vala 2016-10-21 23:51:49.434036000 +0900
++++ src/wingpanel/wingpanel-interface/Settings.vala.new 2016-10-22 00:33:49.443163806 +0900
+@@ -17,7 +17,7 @@
+ * Boston, MA 02111-1307, USA.
+ */
+
+-public class WingpanelInterface.AnimationSettings : Granite.Services.Settings {
++/* public class WingpanelInterface.AnimationSettings : Granite.Services.Settings {
+ public bool enable_animations { get; set; }
+ public int open_duration { get; set; }
+ public int snap_duration { get; set; }
+@@ -39,4 +39,4 @@
+
+ return instance;
+ }
+-}
+\ No newline at end of file
++} */
+--- src/wingpanel/wingpanel-interface/Utils.vala 2016-10-21 23:51:49.434036000 +0900
++++ src/wingpanel/wingpanel-interface/Utils.vala.new 2016-10-22 00:34:59.172928972 +0900
+@@ -22,7 +22,7 @@
+ * related to it are copied from Gala.DBus.
+ */
+
+-namespace WingpanelInterface.Utils {
++/* namespace WingpanelInterface.Utils {
+ private const double SATURATION_WEIGHT = 1.5;
+ private const double WEIGHT_THRESHOLD = 1.0;
+
+@@ -92,7 +92,7 @@
+ * plank's lib/Drawing/DrawingService.vala average_color()
+ * http://bazaar.launchpad.net/~docky-core/plank/trunk/view/head:/lib/Drawing/DrawingService.vala
+ */
+- for (int y = y_start; y < height; y++) {
++ /* for (int y = y_start; y < height; y++) {
+ for (int x = x_start; x < width; x++) {
+ int i = y * width * 4 + x * 4;
+
+@@ -110,7 +110,7 @@
+ delta = max - min;
+
+ /* prefer colored pixels over shades of grey */
+- score = SATURATION_WEIGHT * (delta == 0 ? 0.0 : delta / max);
++ /*score = SATURATION_WEIGHT * (delta == 0 ? 0.0 : delta / max);
+
+ rTotal += score * r;
+ gTotal += score * g;
+@@ -161,7 +161,7 @@
+ * if saturation isn't reasonable enough
+ * s = 0.0 -> f = 0.0 ; s = WEIGHT_THRESHOLD -> f = 1.0
+ */
+- if (scoreTotal <= WEIGHT_THRESHOLD) {
++ /* if (scoreTotal <= WEIGHT_THRESHOLD) {
+ var f = 1.0 / WEIGHT_THRESHOLD * scoreTotal;
+ var rf = 1.0 - f;
+
+@@ -171,7 +171,7 @@
+ }
+
+ /* there shouldn't be values larger then 1.0 */
+- var max_val = double.max (rTotal, double.max (gTotal, bTotal));
++ /* var max_val = double.max (rTotal, double.max (gTotal, bTotal));
+
+ if (max_val > 1.0) {
+ bTotal /= max_val;
+@@ -196,4 +196,4 @@
+ return { rTotal, gTotal, bTotal, mean, variance, mean_acutance };
+ }
+
+-}
++} */
diff --git a/wingpanel.install b/wingpanel.install
new file mode 100644
index 000000000000..0635cceb4eac
--- /dev/null
+++ b/wingpanel.install
@@ -0,0 +1,14 @@
+post_install() {
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+ gtk-update-icon-cache -ftq /usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+# vim: ts=2 sw=2 et: