summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOlivier Brunel2015-11-14 18:07:14 +0100
committerOlivier Brunel2015-11-14 18:17:45 +0100
commitf40eb7d05962152c17d427d8c7bfb8196850ba19 (patch)
treeada83a1fe03bfce3d0a2cc77b31c1c4f398e32d2
downloadaur-f40eb7d05962152c17d427d8c7bfb8196850ba19.tar.gz
Add anopa-musl
Signed-off-by: Olivier Brunel <jjk@jjacky.com>
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD32
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cc181cea83fc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = anopa-musl
+ pkgdesc = init system/service manager built around s6 supervision suite [musl]
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = http://jjacky.com/anopa
+ arch = i686
+ arch = x86_64
+ license = GPL3+
+ makedepends = musl
+ makedepends = skalibs-musl
+ depends = execline-musl
+ depends = s6-musl
+ provides = anopa
+ conflicts = anopa
+ options = staticlibs
+ source = http://jjacky.com/anopa/anopa-0.3.0.tar.gz
+ sha256sums = 1f1891c063b5f4fc3a0c42d1e61411c2f6d6bfb64d3b84c4295acc78af85a72a
+
+pkgname = anopa-musl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6424839d6840
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: jjacky
+_pkgname=anopa
+pkgname=$_pkgname-musl
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="init system/service manager built around s6 supervision suite [musl]"
+arch=('i686' 'x86_64')
+url="http://jjacky.com/anopa"
+license=('GPL3+')
+depends=('execline-musl' 's6-musl')
+makedepends=('musl' 'skalibs-musl')
+options=('staticlibs')
+source=(http://jjacky.com/$_pkgname/$_pkgname-$pkgver.tar.gz)
+sha256sums=('1f1891c063b5f4fc3a0c42d1e61411c2f6d6bfb64d3b84c4295acc78af85a72a')
+provides=($_pkgname)
+conflicts=($_pkgname)
+
+build() {
+ cd "$_pkgname-$pkgver"
+
+ export CPPFLAGS='-nostdinc -isystem /usr/lib/musl/include -isystem /usr/include'
+ export CC="musl-gcc"
+ ./configure --enable-static-libc --bindir=/usr/bin --libexecdir=/usr/lib/anopa
+ make
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: