summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlashbunny2009-08-12 22:17:38 -0400
committerSlashbunny2009-08-12 22:17:38 -0400
commitf41bb3e59344ccc527a34481cd7d0e59f5b29dca (patch)
treee93aa0b33af7b69f9dcf366395c4eabca12c0349
downloadaur-f41bb3e59344ccc527a34481cd7d0e59f5b29dca.tar.gz
Initial commit of personal PKGBUILDs for Arch Linux
-rw-r--r--.SRCINFO28
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD72
-rw-r--r--quake3-smp.launcher6
-rw-r--r--quake3.desktop12
-rw-r--r--quake3.install31
-rw-r--r--quake3.launcher6
-rw-r--r--quake3ded.launcher6
8 files changed, 166 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..41b15ec5fa83
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = quake3
+ pkgdesc = The stock Quake 3 Arena binaries. PunkBuster Compatible.
+ pkgver = 1.32c
+ pkgrel = 2
+ url = http://www.quake3arena.com/
+ install = quake3.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = unzip
+ conflicts = ioquake3-svn
+ source = quake3.install
+ source = quake3.desktop
+ source = quake3.launcher
+ source = quake3-smp.launcher
+ source = quake3ded.launcher
+ source = ftp://ftp.idsoftware.com/idstuff/quake3/linux/linuxq3apoint-1.32b-3.x86.run
+ source = ftp://ftp.idsoftware.com/idstuff/quake3/quake3-1.32c.zip
+ md5sums = df46c620394b94dad07bcee2a25aa2ce
+ md5sums = 4b3656ccf6b6f6967f53e0977d7e5c0a
+ md5sums = dbb6faaf7ffdbd4dc3c1fd2639a2923b
+ md5sums = 413af8ac8dcdcfffb35a10577e7b48ba
+ md5sums = 8f23bbc33ba5b0e42131f18b6771c4a3
+ md5sums = c71fdddccb20e8fc393d846e9c61d685
+ md5sums = 5e55095e654732063621a2ffa95a2da3
+
+pkgname = quake3
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e4f398dc5b3a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg/
+*.pkg.tar.xz
+*.pkg.tar
+*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..95254dd1793a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,72 @@
+# Contributor: Slash <demodevil5[at]yahoo[dot]com>
+
+pkgname=quake3
+pkgver=1.32c
+pkgrel=2
+pkgdesc="The stock Quake 3 Arena binaries. PunkBuster Compatible."
+url="http://www.quake3arena.com/"
+license=('GPL')
+arch=('i686' 'x86_64')
+[ "${CARCH}" = "i686" ] && depends=('libgl' 'libxext')
+[ "${CARCH}" = "x86_64" ] && depends=('lib32-libgl' 'lib32-libxext')
+makedepends=('unzip')
+conflicts=('ioquake3-svn')
+install=quake3.install
+source=('quake3.install' 'quake3.desktop' 'quake3.launcher' 'quake3-smp.launcher' 'quake3ded.launcher' \
+'ftp://ftp.idsoftware.com/idstuff/quake3/linux/linuxq3apoint-1.32b-3.x86.run' \
+'ftp://ftp.idsoftware.com/idstuff/quake3/quake3-1.32c.zip')
+md5sums=('df46c620394b94dad07bcee2a25aa2ce'
+ '4b3656ccf6b6f6967f53e0977d7e5c0a'
+ 'dbb6faaf7ffdbd4dc3c1fd2639a2923b'
+ '413af8ac8dcdcfffb35a10577e7b48ba'
+ '8f23bbc33ba5b0e42131f18b6771c4a3'
+ 'c71fdddccb20e8fc393d846e9c61d685'
+ '5e55095e654732063621a2ffa95a2da3')
+
+build() {
+ cd $startdir/src
+
+ # Create Destination Package Directories
+ install -d $startdir/pkg/opt/quake3/{baseq3,missionpack}
+
+ # Extract Files from Installer
+ chmod +x $startdir/src/linuxq3apoint-1.32b-3.x86.run
+ $startdir/src/linuxq3apoint-1.32b-3.x86.run --tar xf
+
+ # Install BaseQ3 pk3 files
+ install -m 644 -t $startdir/pkg/opt/quake3/baseq3/ \
+ $startdir/src/baseq3/*.pk3
+
+ # Install Missionpack pk3 files
+ install -m 644 -t $startdir/pkg/opt/quake3/missionpack/ \
+ $startdir/src/missionpack/*.pk3
+
+ # Install PB Files
+ chown -R root:root $startdir/src/pb
+ mv $startdir/src/pb $startdir/pkg/opt/quake3/
+
+ # Install 1.32c Binaries
+ install -m 755 -t $startdir/pkg/opt/quake3/ \
+ $startdir/src/Quake\ III\ Arena\ 1.32c/linux/{q3ded,quake3-smp.x86,quake3.x86}
+
+ # Install Launcher (Client)
+ install -D -m 755 $startdir/src/quake3.launcher \
+ $startdir/pkg/usr/bin/quake3
+
+ # Install Launcher (SMP Client)
+ install -D -m 755 $startdir/src/quake3-smp.launcher \
+ $startdir/pkg/usr/bin/quake3-smp
+
+ # Install Launcher (Server)
+ install -D -m 755 $startdir/src/quake3ded.launcher \
+ $startdir/pkg/usr/bin/quake3ded
+
+ # Install Desktop File
+ install -D -m 644 $startdir/src/quake3.desktop \
+ $startdir/pkg/usr/share/applications/quake3.desktop
+
+ # Install Icon File
+ install -D -m 644 $startdir/src/quake3.xpm \
+ $startdir/pkg/usr/share/pixmaps/quake3.xpm
+}
+
diff --git a/quake3-smp.launcher b/quake3-smp.launcher
new file mode 100644
index 000000000000..e77ac3d3e4c3
--- /dev/null
+++ b/quake3-smp.launcher
@@ -0,0 +1,6 @@
+#!/bin/bash
+
+cd "/opt/quake3"
+./quake3-smp.x86 $*
+exit $?
+
diff --git a/quake3.desktop b/quake3.desktop
new file mode 100644
index 000000000000..5f54e927dcba
--- /dev/null
+++ b/quake3.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Quake III Arena
+GenericName=Quake III
+Comment=Quake III Arena Client
+Exec=/usr/bin/quake3
+Icon=/usr/share/pixmaps/quake3.xpm
+StartupNotify=true
+Terminal=false
+Type=Application
+Categories=Qt;KDE;GNOME;Application;Game;
+
diff --git a/quake3.install b/quake3.install
new file mode 100644
index 000000000000..70ada647c34a
--- /dev/null
+++ b/quake3.install
@@ -0,0 +1,31 @@
+
+post_install() {
+ echo ">>>"
+ echo ">>>>To play Q3 with the Retail Version:"
+ echo ">>> Move the pak0.pk3 file from the original game CD to"
+ echo ">>> /opt/quake3/baseq3/"
+ echo ">>>"
+ echo ">>>>To play Q3 with the Demo Version:"
+ echo ">>> You need the demoq3/pak0.pk3 from the demo installer. The"
+ echo ">>> qvm files inside that pk3 file will not work, so you have"
+ echo ">>> to copy or link the .so files in the baseq3/ directory to"
+ echo ">>> /opt/quake3/demoq3/ with the pak0.pk3 file."
+ echo ">>>"
+ echo ">>>>When you have the .pk3 file(s) installed, run the game:"
+ echo ">>> quake3"
+ echo ">>>"
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ /bin/true
+}
+
+op=$1
+shift
+
+$op $*
+
diff --git a/quake3.launcher b/quake3.launcher
new file mode 100644
index 000000000000..75dcead5b027
--- /dev/null
+++ b/quake3.launcher
@@ -0,0 +1,6 @@
+#!/bin/bash
+
+cd "/opt/quake3"
+./quake3.x86 $*
+exit $?
+
diff --git a/quake3ded.launcher b/quake3ded.launcher
new file mode 100644
index 000000000000..e531a71be135
--- /dev/null
+++ b/quake3ded.launcher
@@ -0,0 +1,6 @@
+#!/bin/bash
+
+cd "/opt/quake3"
+./q3ded $*
+exit $?
+