summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorluspi2024-01-18 17:40:30 -0600
committerluspi2024-01-18 17:40:30 -0600
commitf41df486784ef5773d1cf2719e7c84f26e34d8f9 (patch)
tree5b5baa6f49ceb742d5b0c3d38e4191717d188ec7
parent47f6c7d6b002b2e01de8a141c723724bf3237bd2 (diff)
downloadaur-f41df486784ef5773d1cf2719e7c84f26e34d8f9.tar.gz
add missing dependency for pychromecast, add some notes
-rw-r--r--.SRCINFO1
-rwxr-xr-xPKGBUILD19
2 files changed, 14 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c696ae2eca33..aeee93a4c9a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -23,6 +23,7 @@ pkgbase = photoqt
depends = pugixml
depends = mpv
depends = resvg
+ depends = python-pychromecast
optdepends = libqpsd-git: PSB/PSD support
optdepends = xcftools: XCF support
optdepends = poppler-qt6: PDF support
diff --git a/PKGBUILD b/PKGBUILD
index cb631fa50697..788c20e97566 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,9 +8,7 @@ pkgdesc="Fast and highly configurable image viewer with a simple and nice interf
arch=('x86_64')
url="http://photoqt.org/"
license=('GPL2')
-depends=('exiv2' 'imagemagick' 'qt6-imageformats' 'qt6-multimedia' 'qt6-svg' 'qt6-declarative' 'qt6-location' 'qt6-positioning' 'libraw' 'hicolor-icon-theme' 'libarchive' 'kimageformats5' 'pugixml' 'mpv' 'resvg')
-# To use GraphicsMagick instead of ImageMagick replace it in the depends array above
-# These dependencies are disabled in the cmake call below: 'freeimage' 'devil-ilut' 'poppler-qt5'
+depends=('exiv2' 'imagemagick' 'qt6-imageformats' 'qt6-multimedia' 'qt6-svg' 'qt6-declarative' 'qt6-location' 'qt6-positioning' 'libraw' 'hicolor-icon-theme' 'libarchive' 'kimageformats5' 'pugixml' 'mpv' 'resvg' 'python-pychromecast')
optdepends=('libqpsd-git: PSB/PSD support'
'xcftools: XCF support'
'poppler-qt6: PDF support')
@@ -18,12 +16,21 @@ makedepends=('cmake' 'qt6-tools' 'extra-cmake-modules')
source=(https://photoqt.org/downloads/source/$pkgname-$pkgver.tar.gz)
sha256sums=('394aaccaf9afe9c7090f371601e4b538e98ad9e5ce08480692dcfa184533a00f')
+# NOTE
+# To use GraphicsMagick instead of ImageMagick replace it in the depends array above and change
+# '-DIMAGEMAGICK=ON -DGRAPHICSMAGICK=OFF' to '-DIMAGEMAGICK=OFF -DGRAPHICSMAGICK=ON' in the cmake call below.
+
+# NOTE
+# If you want to build PhotoQt without python-pychromecast remove it from the depends array
+# and change '-DCHROMECAST=ON' to '-DCHROMECAST=OFF' in the cmake call below.
+
+# NOTE
+# These dependencies are currently disabled in the cmake call below:
+# 'freeimage' 'devil-ilut' 'poppler-qt5' 'libvips'
+
prepare() {
cd $srcdir/$pkgname-$pkgver
- # To build PhotoQt with less features, add -Dxxxx=OFF to
- # the next line (where xxxx is the respective CMake option).
- # to use GraphicsMagick instead of ImageMagick add: -DIMAGEMAGICK=OFF -DGRAPHICSMAGICK=ON
cmake . -DCMAKE_INSTALL_PREFIX=/usr -DFREEIMAGE=OFF -DDEVIL=OFF -DPOPPLER=OFF -DQTPDF=ON -DIMAGEMAGICK=ON -DGRAPHICSMAGICK=OFF -DLIBVIPS=OFF -DVIDEO_MPV=ON -DCHROMECAST=ON -DRESVG=ON
}