summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYichao Zhou2016-05-19 00:42:29 -0700
committerYichao Zhou2016-05-19 00:42:29 -0700
commitf42cd432abd8727a5e19a55cd303df7dea921f36 (patch)
treebbfe86ce4eedb0626b37cf66c1923331f73a243f
parenta567d68f5288be55a72d292a0f2dd4f7b24709b6 (diff)
downloadaur-f42cd432abd8727a5e19a55cd303df7dea921f36.tar.gz
Remove hinting; version bump
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD48
-rw-r--r--evince-lcdfilter.install13
-rw-r--r--evince-poppler-subpixel.patch12
4 files changed, 48 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 087db3c19fe3..67416bf9fbbb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
# Generated by mksrcinfo v8
-# Wed Jan 6 07:46:52 UTC 2016
+# Thu May 19 07:42:00 UTC 2016
pkgbase = evince-lcdfilter
pkgdesc = Document viewer (PDF, Postscript, djvu, tiff, dvi, XPS, SyncTex support with gedit, comics books (cbr,cbz,cb7 and cbt))
- pkgver = 3.18.2
- pkgrel = 4
+ pkgver = 3.20.0
+ pkgrel = 2
url = https://wiki.gnome.org/Apps/Evince
- install = evince-lcdfilter.install
arch = i686
arch = x86_64
groups = gnome
@@ -13,32 +12,33 @@ pkgbase = evince-lcdfilter
makedepends = itstool
makedepends = libnautilus-extension
makedepends = texlive-bin
- makedepends = intltool
makedepends = gobject-introspection
+ makedepends = intltool
makedepends = docbook-xsl
makedepends = python
+ makedepends = gtk-doc
depends = gtk3
depends = libgxps
depends = libspectre
depends = gsfonts
- depends = poppler-glib-lcdfilter
+ depends = poppler-glib
depends = djvulibre
depends = t1lib
- depends = libsecret
- depends = desktop-file-utils
depends = dconf
+ depends = libsecret
depends = gsettings-desktop-schemas
depends = gnome-desktop
depends = libarchive
+ depends = gst-plugins-base-libs
optdepends = texlive-bin: DVI support
optdepends = gvfs: bookmark support and session saving
- provides = evince=3.18.2
+ provides = evince=3.20.0
conflicts = evince
options = !emptydirs
- source = http://ftp.gnome.org/pub/gnome/sources/evince/3.18/evince-3.18.2.tar.xz
+ source = https://download.gnome.org/sources/evince/3.20/evince-3.20.0.tar.xz
source = evince-poppler-subpixel.patch
- sha256sums = 42ad6c7354d881a9ecab136ea84ff867acb942605bcfac48b6c12e1c2d8ecb17
- sha256sums = 582d6e7125713d1b64be3f7dc73af2fa0777d7fed39bfcad0b28c35d1401d975
+ sha256sums = cf8358a453686c2a7f85d245f83fe918c0ce02eb6532339f3e02e31249a5a280
+ sha256sums = SKIP
pkgname = evince-lcdfilter
diff --git a/PKGBUILD b/PKGBUILD
index 15bc83e4ce2f..d562d3c7a38b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,37 +2,51 @@
_pkgname=evince
pkgname=evince-lcdfilter
-pkgver=3.18.2
-pkgrel=4
+pkgver=3.20.0
+pkgrel=2
pkgdesc="Document viewer (PDF, Postscript, djvu, tiff, dvi, XPS, SyncTex support with gedit, comics books (cbr,cbz,cb7 and cbt))"
url="https://wiki.gnome.org/Apps/Evince"
arch=(i686 x86_64)
license=(GPL)
-depends=(gtk3 libgxps libspectre gsfonts poppler-glib-lcdfilter djvulibre t1lib libsecret desktop-file-utils dconf gsettings-desktop-schemas gnome-desktop libarchive)
-makedepends=(itstool libnautilus-extension texlive-bin intltool gobject-introspection docbook-xsl python)
+depends=(gtk3 libgxps libspectre gsfonts poppler-glib djvulibre t1lib dconf
+ libsecret gsettings-desktop-schemas gnome-desktop libarchive
+ gst-plugins-base-libs)
+makedepends=(itstool libnautilus-extension texlive-bin gobject-introspection
+ intltool docbook-xsl python gtk-doc)
optdepends=('texlive-bin: DVI support'
- 'gvfs: bookmark support and session saving')
+ 'gvfs: bookmark support and session saving')
provides=("evince=$pkgver")
conflicts=("evince")
groups=(gnome)
-install=evince-lcdfilter.install
options=('!emptydirs')
-source=(http://ftp.gnome.org/pub/gnome/sources/$_pkgname/${pkgver:0:4}/$_pkgname-$pkgver.tar.xz
+source=(https://download.gnome.org/sources/$_pkgname/${pkgver:0:4}/$_pkgname-$pkgver.tar.xz
evince-poppler-subpixel.patch)
-sha256sums=('42ad6c7354d881a9ecab136ea84ff867acb942605bcfac48b6c12e1c2d8ecb17'
- '582d6e7125713d1b64be3f7dc73af2fa0777d7fed39bfcad0b28c35d1401d975')
+sha256sums=('cf8358a453686c2a7f85d245f83fe918c0ce02eb6532339f3e02e31249a5a280'
+ 'SKIP')
build() {
cd $_pkgname-$pkgver
patch -Np1 -i ../evince-poppler-subpixel.patch
- ./configure --prefix=/usr --sysconfdir=/etc \
- --localstatedir=/var --libexecdir=/usr/lib/evince \
- --disable-static --enable-nautilus \
- --enable-pdf --enable-tiff \
- --enable-djvu --enable-dvi \
- --enable-t1lib --enable-comics \
- --disable-scrollkeeper --disable-schemas-compile \
- --enable-introspection --disable-browser-plugin
+
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ --libexecdir=/usr/lib/$_pkgname \
+ --disable-static \
+ --enable-compile-warnings=minimum \
+ --enable-introspection \
+ --enable-nautilus \
+ --enable-pdf \
+ --enable-tiff \
+ --enable-djvu \
+ --enable-dvi \
+ --enable-t1lib \
+ --enable-comics \
+ --enable-gtk-doc \
+ --enable-multimedia \
+ --disable-schemas-compile \
+ --disable-browser-plugin
+
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+
make
}
diff --git a/evince-lcdfilter.install b/evince-lcdfilter.install
deleted file mode 100644
index 1571179cae27..000000000000
--- a/evince-lcdfilter.install
+++ /dev/null
@@ -1,13 +0,0 @@
-post_install() {
- glib-compile-schemas /usr/share/glib-2.0/schemas
- update-desktop-database -q
- gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}
diff --git a/evince-poppler-subpixel.patch b/evince-poppler-subpixel.patch
index 93170ec6ed2c..5ee4cc19a518 100644
--- a/evince-poppler-subpixel.patch
+++ b/evince-poppler-subpixel.patch
@@ -1,12 +1,12 @@
diff --git a/backend/pdf/ev-poppler.cc b/backend/pdf/ev-poppler.cc
-index f3a6510..4ab249a 100644
+index 214094f..8a09909 100644
--- a/backend/pdf/ev-poppler.cc
+++ b/backend/pdf/ev-poppler.cc
-@@ -393,11 +393,28 @@ pdf_page_render (PopplerPage *page,
+@@ -393,11 +393,26 @@ pdf_page_render (PopplerPage *page,
cairo_t *cr;
double page_width, page_height;
double xscale, yscale;
-+ gboolean subpixel_rendering;
++ gboolean subpixel_rendering;
+ cairo_font_options_t *fo;
surface = cairo_image_surface_create (CAIRO_FORMAT_ARGB32,
@@ -15,13 +15,11 @@ index f3a6510..4ab249a 100644
+ fo = cairo_font_options_create ();
+ cairo_get_font_options (cr, fo);
-+ cairo_font_options_set_hint_style (fo, CAIRO_HINT_STYLE_SLIGHT);
-+
+ subpixel_rendering = poppler_page_support_subpixel_rendering (page);
++ // printf("subpixel_rendering: %d\n", subpixel_rendering);
+ if (subpixel_rendering) {
+ cairo_set_source_rgb (cr, 1., 1., 1.);
+ cairo_paint (cr);
-+
+ cairo_font_options_set_antialias (fo, CAIRO_ANTIALIAS_SUBPIXEL);
+ cairo_font_options_set_subpixel_order (fo, CAIRO_SUBPIXEL_ORDER_RGB);
+ }
@@ -31,7 +29,7 @@ index f3a6510..4ab249a 100644
switch (rc->rotation) {
case 90:
cairo_translate (cr, width, 0);
-@@ -420,9 +437,11 @@ pdf_page_render (PopplerPage *page,
+@@ -420,9 +435,11 @@ pdf_page_render (PopplerPage *page,
cairo_rotate (cr, rc->rotation * G_PI / 180.0);
poppler_page_render (page, cr);