summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Mezin2015-08-10 18:42:19 +0600
committerAlexander Mezin2015-08-10 18:42:19 +0600
commitf44ac7081ee1d72b1d69267d1726d55321745dac (patch)
treecc1322a287eec4395e5ef69faf849b3bfa197533
downloadaur-f44ac7081ee1d72b1d69267d1726d55321745dac.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD38
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..02ce746dabb3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = kcm-pointing-devices-git
+ pkgdesc = Mouse/touchpad configuration module for KDE
+ pkgver = r45.5989dd6
+ pkgrel = 1
+ url = https://github.com/amezin/pointing-devices-kcm
+ arch = i686
+ arch = x86_64
+ groups = plasma
+ license = GPL
+ makedepends = extra-cmake-modules
+ makedepends = qt5-tools
+ depends = kded
+ depends = kcmutils
+ depends = kdeclarative
+ depends = libxcb-git
+ depends = xcb-proto-git
+ source = git://github.com/amezin/pointing-devices-kcm.git
+ md5sums = SKIP
+
+pkgname = kcm-pointing-devices-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..39dc4bf2d2ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+pkgname=kcm-pointing-devices-git
+pkgver=r45.5989dd6
+pkgrel=1
+pkgdesc="Mouse/touchpad configuration module for KDE"
+arch=('i686' 'x86_64')
+url='https://github.com/amezin/pointing-devices-kcm'
+license=('GPL')
+depends=('kded' 'kcmutils' 'kdeclarative' 'libxcb-git' 'xcb-proto-git')
+makedepends=('extra-cmake-modules' 'qt5-tools')
+source=("git://github.com/amezin/pointing-devices-kcm.git")
+groups=('plasma')
+md5sums=('SKIP')
+
+pkgver() {
+ cd pointing-devices-kcm
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../pointing-devices-kcm \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_INSTALL_DIR=lib \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
+ -DSYSCONF_INSTALL_DIR=/etc \
+ -DBUILD_TESTING=OFF
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}