summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorc0re1002023-06-22 16:35:13 +0800
committerc0re1002023-06-22 16:35:13 +0800
commitf4c43865b00fe674591eb707c87e3328b1c826ba (patch)
treee057035ef3b51220c3a5351d6bf5173f21dcd322
parentd1daaf70bb633f06dc5b8759c7255719f9df7d47 (diff)
downloadaur-f4c43865b00fe674591eb707c87e3328b1c826ba.tar.gz
Fix Qt6 build
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD17
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f293f5edb6e0..ab05eab22da6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qbittorrent-enhanced-nox-git
pkgdesc = A bittorrent client powered by C++, Qt6 and the good libtorrent library (Enhanced Edition)
pkgver = 4.5.4.10.r0.g416904b36
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/c0re100/qBittorrent-Enhanced-Edition
arch = arm
arch = armv6h
@@ -11,6 +11,7 @@ pkgbase = qbittorrent-enhanced-nox-git
arch = x86_64
license = custom
license = GPL
+ makedepends = cmake
makedepends = boost
makedepends = git
makedepends = qt6-tools
diff --git a/PKGBUILD b/PKGBUILD
index d65294069dc9..30d81ef8d1c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=qbittorrent-enhanced-nox-git
pkgver=4.5.4.10.r0.g416904b36
-pkgrel=1
+pkgrel=2
pkgdesc="A bittorrent client powered by C++, Qt6 and the good libtorrent library (Enhanced Edition)"
arch=('arm' 'armv6h' 'armv7h' 'aarch64' 'i686' 'x86_64')
url="https://github.com/c0re100/qBittorrent-Enhanced-Edition"
license=('custom' 'GPL')
depends=('libtorrent-rasterbar' 'qt6-base')
-makedepends=('boost' 'git' 'qt6-tools')
+makedepends=('cmake' 'boost' 'git' 'qt6-tools')
optdepends=('python: needed for torrent search tab')
conflicts=('qbittorrent-nox')
provides=('qbittorrent-nox')
@@ -27,16 +27,17 @@ pkgver() {
build() {
cd ${pkgname%-*}
- # tell qmake not to break makepkg's debug/!strip options
- export QBT_ADD_CONFIG='nostrip'
-
- ./configure --prefix=/usr --disable-gui CXXFLAGS="-std=c++17"
- make
+ cmake -B build -S . \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DQT6=ON \
+ -DGUI=OFF \
+ -DSYSTEMD=ON
+ cmake --build build
}
package() {
cd ${pkgname%-*}
- make INSTALL_ROOT="$pkgdir/" install
+ DESTDIR="$pkgdir" cmake --install build
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}