summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmolith2023-09-18 02:01:57 -0400
committerAmolith2023-09-18 02:01:57 -0400
commitf51bb07b49a0a2b03e30656ba6eea4f9967caca7 (patch)
tree6d78b1881b1d71d462c956a17c983f9d3aac61b2
parent3c4190cc3ffe0c74a3eb38786d7a4744e089dd7b (diff)
downloadaur-f51bb07b49a0a2b03e30656ba6eea4f9967caca7.tar.gz
Bump version and clean up PKGBUILD
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD20
2 files changed, 11 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b8bafd823c78..b326e22c608a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hey-mail-bin
pkgdesc = Hey Mail desktop app
- pkgver = 1.2.11
+ pkgver = 1.2.12
pkgrel = 1
url = https://hey.com/apps/
arch = x86_64
@@ -21,7 +21,8 @@ pkgbase = hey-mail-bin
depends = libnotify
depends = libappindicator-gtk2
depends = libappindicator-gtk3
- source = https://api.snapcraft.io/api/v1/snaps/download/lfWUNpR7PrPGsDfuxIhVxbj0wZHoH7bK_21.snap
- md5sums = 901b9dbecc18bd4116223217dcad068e
+ provides = hey-mail
+ source = https://api.snapcraft.io/api/v1/snaps/download/lfWUNpR7PrPGsDfuxIhVxbj0wZHoH7bK_22.snap
+ md5sums = 95a855f53a48ae911780b0f30dcbc8ce
pkgname = hey-mail-bin
diff --git a/PKGBUILD b/PKGBUILD
index 55ce60f0a0f1..d2add9646b37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: Mykyta Poturai <mykyta.poturai@tutanota.com>
+# Maintainer: Amolith <amolith@secluded.site>
pkgname=hey-mail-bin
-pkgver=1.2.11
+pkgver=1.2.12
pkgrel=1
pkgdesc="Hey Mail desktop app"
url="https://hey.com/apps/"
@@ -8,20 +9,13 @@ arch=('x86_64')
license=('Proprietary')
depends=('c-ares' 'ffmpeg' 'gtk3' 'http-parser' 'libevent' 'libvpx' 'libxslt' 'libxss' 'minizip' 'nss' 're2' 'snappy' 'libnotify' 'libappindicator-gtk2' 'libappindicator-gtk3')
makedepends=('squashfs-tools')
-checkdepends=()
-optdepends=()
-provides=()
+provides=('hey-mail')
conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
-SNAPNAME="lfWUNpR7PrPGsDfuxIhVxbj0wZHoH7bK_21.snap"
+SNAPNAME="lfWUNpR7PrPGsDfuxIhVxbj0wZHoH7bK_22.snap"
source=("https://api.snapcraft.io/api/v1/snaps/download/$SNAPNAME")
-md5sums=('901b9dbecc18bd4116223217dcad068e')
+md5sums=('95a855f53a48ae911780b0f30dcbc8ce')
-#curl -H 'Snap-Device-Series: 16' http://api.snapcraft.io/v2/snaps/info/hey-mail
+# curl -H 'Snap-Device-Series: 16' http://api.snapcraft.io/v2/snaps/info/hey-mail | jq
build() {
unsquashfs -force -dest root $SNAPNAME
}
@@ -38,5 +32,5 @@ package() {
rm -rf "$pkgdir/opt/hey-mail/libGLESv2.so"
rm -rf "$pkgdir/opt/hey-mail/libEGL.so"
ln -s /opt/hey-mail/hey-mail "$pkgdir/usr/bin/hey-mail"
- sed "s/\${SNAP}/\/opt\/hey-mail/" root/meta/gui/hey-mail.desktop > "$pkgdir/usr/share/applications/hey-mail.desktop"
+ sed "s/\${SNAP}/\/opt\/hey-mail/" root/meta/gui/hey-mail.desktop > "$pkgdir/usr/share/applications/hey-mail.desktop"
}