summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrevel2019-02-05 09:09:05 +0100
committerrevel2019-02-05 09:09:05 +0100
commitf51e8d7f97a622bd934fa058056a9220d5a653f9 (patch)
tree05f8a97683a2c1ad5504e6f3cce49ae84e95dd9f
parentbf0e97dff397c8ba99b0b0dadf9414683de3f1b3 (diff)
downloadaur-f51e8d7f97a622bd934fa058056a9220d5a653f9.tar.gz
- fixes building mysql module against mariadb libs
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d451f792c6a..b2e06d097a6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Tue Feb 5 08:08:44 UTC 2019
pkgbase = falcon
- pkgdesc = a general purpose untyped language, based on a Virtual Machine executing portable pseudo codes
+ pkgdesc = An Open Source, simple, fast and powerful programming language, easy to learn and to feel comfortable with, and a scripting engine ready to empower mission-critical multithreaded applications.
pkgver = 0.9.6.8
- pkgrel = 4
+ pkgrel = 5
url = http://falconpl.org
arch = i686
arch = x86_64
@@ -17,7 +19,7 @@ pkgbase = falcon
depends = sdl_ttf
depends = sdl_mixer
depends = sqlite
- depends = libmysqlclient
+ depends = mariadb-libs
depends = postgresql-libs
source = http://falconpl.org/project_dl/_official_rel/Falcon-0.9.6.8.tgz
md5sums = 8435f6f2fe95097ac2fbe000da97c242
diff --git a/PKGBUILD b/PKGBUILD
index 8f3bb91779db..39ad6dca02f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
pkgname=falcon
pkgver=0.9.6.8
-pkgrel=4
-pkgdesc='a general purpose untyped language, based on a Virtual Machine executing portable pseudo codes'
+pkgrel=5
+pkgdesc='An Open Source, simple, fast and powerful programming language, easy to learn and to feel comfortable with, and a scripting engine ready to empower mission-critical multithreaded applications.'
arch=('i686' 'x86_64')
url='http://falconpl.org'
license=('GPL2'
'custom:FPLLv1.1')
-depends=('bison' 'gtk2' 'gd' 'curl' 'dbus' 'sdl_image' 'sdl_ttf' 'sdl_mixer' 'sqlite' 'libmysqlclient' 'postgresql-libs')
+depends=('bison' 'gtk2' 'gd' 'curl' 'dbus' 'sdl_image' 'sdl_ttf' 'sdl_mixer' 'sqlite' 'mariadb-libs' 'postgresql-libs')
makedepends=('cmake')
source=("http://falconpl.org/project_dl/_official_rel/Falcon-$pkgver.tgz"
# 'mongodb-module.patch'
@@ -20,6 +20,7 @@ sha256sums=('f4b00983e7f91a806675d906afd2d51dcee048f12ad3af4b1dadd92059fa44b9')
prepare() {
cd "Falcon-$pkgver"
# patch -p1 -i ../mongodb-module.patch
+ sed '20 i #include <server/mysql.h>' -i modules/native/dbi/mysql/mysql_mod.cpp
}
build() {