summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2018-12-06 02:47:32 +0800
committerUniversebenzene2018-12-06 02:47:32 +0800
commitf52006725d1d904910546b4d7ab226781820aa68 (patch)
tree80d752c44531656ae62902e08db019dde432f92d
parent9154b7e22a215147c250d9852aade463911a6b90 (diff)
downloadaur-f52006725d1d904910546b4d7ab226781820aa68.tar.gz
Update for astropy_helper 3.1
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 79c8b937f087..b1532855dd02 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Thu Feb 15 17:06:08 UTC 2018
+# Wed Dec 5 18:46:59 UTC 2018
pkgbase = python-pydl
pkgdesc = Python replacements for functions that are part of the IDL built-in library or part of astronomical IDL libraries
pkgver = 0.6.0
@@ -14,8 +14,7 @@ pkgbase = python-pydl
makedepends = python-astropy-helpers
makedepends = python2-astropy-helpers
makedepends = python-sphinx
- makedepends = python-numpydoc
- makedepends = python-matplotlib
+ makedepends = python-sphinx-astropy
source = https://files.pythonhosted.org/packages/source/p/pydl/pydl-0.6.0.tar.gz
md5sums = 4c024738a89e4229bfa4ce2beb3f4f14
diff --git a/PKGBUILD b/PKGBUILD
index b2cbaf1b06bd..de8ced274671 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgdesc="Python replacements for functions that are part of the IDL built-in lib
arch=('i686' 'x86_64')
url="http://pydl.readthedocs.io/en/latest/"
license=('BSD')
-makedepends=('cython' 'cython2' 'python-astropy' 'python-astropy-helpers' 'python2-astropy-helpers' 'python-sphinx' 'python-numpydoc' 'python-matplotlib')
+makedepends=('cython' 'cython2' 'python-astropy' 'python-astropy-helpers' 'python2-astropy-helpers' 'python-sphinx' 'python-sphinx-astropy')
#checkdepends=('python-pytest-astropy' 'python2-pytest' 'python2-astropy')
source=("https://files.pythonhosted.org/packages/source/p/pydl/pydl-${pkgver}.tar.gz")
md5sums=('4c024738a89e4229bfa4ce2beb3f4f14')
@@ -19,7 +19,7 @@ prepare() {
cp -a ${srcdir}/pydl-${pkgver}{,-py2}
}
-build () {
+build() {
msg "Building Python2"
cd ${srcdir}/pydl-${pkgver}-py2
python2 setup.py build --use-system-libraries --offline
@@ -32,11 +32,11 @@ build () {
python setup.py build_docs
}
-#check(){
-# cd $srcdir/pydl-${pkgver}
+#check() {
+# cd ${srcdir}/pydl-${pkgver}
# python setup.py test
#
-# cd $srcdir/pydl-${pkgver}-py2
+# cd ${srcdir}/pydl-${pkgver}-py2
# python2 setup.py test
#}