summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsballert2018-09-12 22:20:20 +0200
committersballert2018-09-12 22:20:20 +0200
commitf53e3e859df15d94cc8a9e040ffd87675c3d972a (patch)
treecf2a3cb58a1b3b0c88b0dfbf1c7dc9a2b46ea448
downloadaur-f53e3e859df15d94cc8a9e040ffd87675c3d972a.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD34
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..93e418fada44
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = emacs-evil-anzu-git
+ pkgdesc = anzu for Evil
+ pkgver = r23.9bca6ca
+ pkgrel = 1
+ url = https://github.com/syohex/emacs-evil-anzu
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ depends = emacs-anzu
+ provides = emacs-evil-anzu
+ conflicts = emacs-evil-anzu
+ source = git+https://github.com/syohex/emacs-evil-anzu.git
+ sha256sums = SKIP
+
+pkgname = emacs-evil-anzu-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f997fbef1406
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: sballert <sballert@posteo.de>
+
+_gituser="syohex"
+_gitrepo="emacs-evil-anzu"
+
+pkgname=emacs-evil-anzu-git
+pkgver=r23.9bca6ca
+pkgrel=1
+pkgdesc="anzu for Evil"
+url="https://github.com/${_gituser}/${_gitrepo}"
+arch=('any')
+license=('GPL3')
+depends=('emacs' 'emacs-anzu')
+makedepends=('git')
+provides=('emacs-evil-anzu')
+conflicts=('emacs-evil-anzu')
+source=("git+https://github.com/${_gituser}/${_gitrepo}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_gitrepo"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$_gitrepo"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "$_gitrepo"
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/evil-anzu/
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/evil-anzu/
+}