summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Mathis2020-01-17 00:14:36 -0500
committerMatt Mathis2020-01-17 00:14:36 -0500
commitf55ef4d09824997f95be3d1affd9ddc82382ffca (patch)
tree19299b68d878ab028552f74cde75bac660f6a287
parentd977af80cb11a0da20a62b711a85ae47ae3d2b16 (diff)
downloadaur-f55ef4d09824997f95be3d1affd9ddc82382ffca.tar.gz
Updated conflicts, pushed manpages
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 728452ad8956..583e7aa6dddb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wofi-hg
pkgdesc = Rofi-like wlroots launcher
- pkgver = r112.7906ded22800
+ pkgver = r148.0522e8bc4ee9
pkgrel = 1
url = https://hg.sr.ht/~scoopta/wofi
arch = x86_64
@@ -9,6 +9,7 @@ pkgbase = wofi-hg
makedepends = meson
depends = wayland
depends = gtk3
+ conflicts = wofi
source = wofi-hg::hg+https://hg.sr.ht/~scoopta/wofi
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 03a28082fee7..2fe33d54c01f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=wofi-hg
-pkgver=r112.7906ded22800
+pkgver=r148.0522e8bc4ee9
pkgrel=1
pkgdesc="Rofi-like wlroots launcher"
arch=('x86_64')
@@ -7,6 +7,7 @@ url="https://hg.sr.ht/~scoopta/wofi"
license=('GPL3')
depends=('wayland' 'gtk3')
makedepends=('mercurial' 'meson')
+conflicts=('wofi')
source=("${pkgname}::hg+$url")
sha256sums=('SKIP')
pkgver() {
@@ -20,5 +21,11 @@ build() {
}
package() {
mkdir -p "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/share/man/man1"
+ mkdir -p "$pkgdir/usr/share/man/man5"
+ mkdir -p "$pkgdir/usr/share/man/man7"
cp ${pkgname}/build/wofi "$pkgdir/usr/bin/"
+ cp ${pkgname}/man/wofi.1 "$pkgdir/usr/share/man/man1/"
+ cp ${pkgname}/man/wofi.5 "$pkgdir/usr/share/man/man5/"
+ cp ${pkgname}/man/wofi.7 "$pkgdir/usr/share/man/man7/"
} \ No newline at end of file