summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub 'Eremiell' Marek2023-09-01 06:47:41 +0200
committerJakub 'Eremiell' Marek2023-09-01 06:47:41 +0200
commitf5695fcace0e93c189e7d895105007b2fb3dd0d0 (patch)
tree14ac3695a44cf3c8b9df5cbe282e380ea67cf29a
parent3d20578e40b3d4cb7efd5054c0c427f294b7e7f2 (diff)
downloadaur-f5695fcace0e93c189e7d895105007b2fb3dd0d0.tar.gz
🔖 Update package, version 10.0.25-1
* Upstream version update * AVX support for mixing audio * Coroutine support reached next level of maturity * Various bugfixes * See upstream changelog for details * Releases are now GPG signed
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
-rw-r--r--dpp.changelog9
3 files changed, 24 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e9c3e798dbad..2dedf6f6c544 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dpp
pkgdesc = Lightweight and Scalable C++ Discord API Bot Library
- pkgver = 10.0.24
+ pkgver = 10.0.25
pkgrel = 1
url = https://dpp.dev/
install = dpp.install
@@ -9,13 +9,17 @@ pkgbase = dpp
license = Apache
makedepends = cmake
makedepends = pkgconf
+ depends = glibc
depends = gcc-libs
depends = openssl
depends = zlib
depends = opus
depends = libsodium
depends = nlohmann-json
- source = dpp-10.0.24.tar.gz::https://github.com/brainboxdotcc/DPP/archive/refs/tags/v10.0.24.tar.gz
- sha256sums = e5d561b864a7397caeb5616d388ebbd79a8f21077f3b13ac6ccd7e29c746daa9
+ source = https://github.com/brainboxdotcc/DPP/releases/download/v10.0.25/DPP-10.0.25.tar.gz
+ source = https://github.com/brainboxdotcc/DPP/releases/download/v10.0.25/DPP-10.0.25.tar.gz.asc
+ validpgpkeys = EDCEFB1FDAFFAC7952EED46F9927644B850BDD23
+ sha256sums = bd39d24e01748ff4cc34ad7ca0faaa0f53542efd8843d4bcc75566a11f0f248b
+ sha256sums = SKIP
pkgname = dpp
diff --git a/PKGBUILD b/PKGBUILD
index 7fd7d4f2216f..96c98bf1580b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,22 @@
# See also https://github.com/eremiell-aur/dpp
pkgname=dpp
_pkgname=DPP
-pkgver=10.0.24
+pkgver=10.0.25
pkgrel=1
pkgdesc="Lightweight and Scalable C++ Discord API Bot Library"
arch=('x86_64')
url="https://dpp.dev/"
+_url="https://github.com/brainboxdotcc/${_pkgname}"
license=('Apache')
-depends=('gcc-libs' 'openssl' 'zlib' 'opus' 'libsodium' 'nlohmann-json')
+depends=('glibc' 'gcc-libs' 'openssl' 'zlib' 'opus' 'libsodium' 'nlohmann-json')
makedepends=('cmake' 'pkgconf')
install="${pkgname}.install"
changelog="${pkgname}.changelog"
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/brainboxdotcc/${_pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('e5d561b864a7397caeb5616d388ebbd79a8f21077f3b13ac6ccd7e29c746daa9')
+source=("${_url}/releases/download/v${pkgver}/${_pkgname}-${pkgver}.tar.gz"
+ "${_url}/releases/download/v${pkgver}/${_pkgname}-${pkgver}.tar.gz.asc")
+sha256sums=('bd39d24e01748ff4cc34ad7ca0faaa0f53542efd8843d4bcc75566a11f0f248b'
+ 'SKIP')
+validpgpkeys=('EDCEFB1FDAFFAC7952EED46F9927644B850BDD23')
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
diff --git a/dpp.changelog b/dpp.changelog
index 629abd595260..30d8706e6490 100644
--- a/dpp.changelog
+++ b/dpp.changelog
@@ -1,3 +1,12 @@
+# 10.0.25-1 / 2023-09-01
+
+* bump to new library version
+ * coroutine support is reaching next level of maturity
+ * AVX support for mixing audio
+ * various bugfixes
+ * see library changelog for full list
+* releases are now being GPG signed, package reflects that
+
# 10.0.24-1 / 2023-05-25
* bump to new library version