summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkleintux2021-07-31 12:14:47 +0200
committerkleintux2021-07-31 12:14:47 +0200
commitf573223001a072244fc0c1722f4cfa71eae69352 (patch)
tree5ba68e09ea2fdfe96145166599d3eb60cba813ac
downloadaur-f573223001a072244fc0c1722f4cfa71eae69352.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD42
-rw-r--r--robot-ricochet.desktop10
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d2f44fe8d32
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = robot-ricochet
+ pkgdesc = You are a sneaky smuggler, who has had an unlucky encounter with the galactic police bots. Now you must evade capture by destroying the robots that have come aboard.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://codeberg.org/Samsai/mirrored-lasers
+ arch = any
+ license = GPLv3
+ makedepends = rust
+ depends = sdl2
+ depends = sdl2_gfx
+ depends = sdl2_mixer
+ depends = sdl2_image
+ depends = sdl2_ttf
+ provides = robot-ricochet
+ provides = robot-ricochet-level-editor
+ source = robot-ricochet-1.0.tar.gz::https://codeberg.org/Samsai/mirrored-lasers/archive/1.0.tar.gz
+ source = robot-ricochet.desktop
+ sha512sums = 47467423bfe56607604a03038d0731a5499b83dff2644f459f25f4284616d754acc6823ee05c9f93b4ffb9ff96078172d21c126caa9cfc5f2f704a549dc8e911
+ sha512sums = ebed3480deb63c54dbe38375efaf4b1c7e5a770b5cad914c9fb5e7583424d283c7734ce70b15301c1f91efd2ae73d2ad72440c5004d1d0e51b446440b2ca7bdc
+
+pkgname = robot-ricochet
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a03c88fba850
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: kleintux <reg-archlinux AT klein DOT tuxli DOT ch>
+pkgname=robot-ricochet
+_pkgname=mirrored-lasers
+pkgver=1.0
+pkgrel=1
+pkgdesc="You are a sneaky smuggler, who has had an unlucky encounter with the galactic police bots. Now you must evade capture by destroying the robots that have come aboard."
+arch=('any')
+url="https://codeberg.org/Samsai/mirrored-lasers"
+license=('GPLv3')
+makedepends=('rust')
+depends=('sdl2' 'sdl2_gfx' 'sdl2_mixer' 'sdl2_image' 'sdl2_ttf')
+provides=("${pkgname}" "${pkgname}-level-editor")
+source=(
+ "${pkgname}-${pkgver}.tar.gz::https://codeberg.org/Samsai/${_pkgname}/archive/${pkgver}.tar.gz"
+ "${pkgname}.desktop"
+)
+sha512sums=(
+ '47467423bfe56607604a03038d0731a5499b83dff2644f459f25f4284616d754acc6823ee05c9f93b4ffb9ff96078172d21c126caa9cfc5f2f704a549dc8e911'
+ 'ebed3480deb63c54dbe38375efaf4b1c7e5a770b5cad914c9fb5e7583424d283c7734ce70b15301c1f91efd2ae73d2ad72440c5004d1d0e51b446440b2ca7bdc'
+)
+build() {
+ cd "${srcdir}"/"${_pkgname}"
+ cargo build --release
+ cd level-editor
+ cargo build --release
+}
+
+package() {
+ cd "${srcdir}"/"${_pkgname}"
+ mkdir -p "${pkgdir}/usr/bin"
+ mkdir -p "${pkgdir}/opt/${pkgname}/save/"
+ chmod 777 "${pkgdir}/opt/${pkgname}/save/"
+ cp -r data "${pkgdir}/opt/${pkgname}/"
+ ln -s "/opt/${pkgname}/save/save.txt" "${pkgdir}/opt/${pkgname}/save.txt"
+ install -Dm755 "${startdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm755 "icon.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm755 "target/release/${_pkgname}" "${pkgdir}/opt/${pkgname}/${pkgname}"
+ install -Dm755 "level-editor/target/release/level-editor" "${pkgdir}/usr/bin/${pkgname}-level-editor"
+ echo -e "#!/bin/sh\ncd /opt/${pkgname}\n./${pkgname}" > "${pkgdir}/usr/bin/${pkgname}"
+ chmod +x "${pkgdir}/usr/bin/${pkgname}"
+}
diff --git a/robot-ricochet.desktop b/robot-ricochet.desktop
new file mode 100644
index 000000000000..3828e8d8535a
--- /dev/null
+++ b/robot-ricochet.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Robot Ricochet
+Comment=You are a sneaky smuggler, who has had an unlucky encounter with the galactic police bots. Now you must evade capture by destroying the robots that have come aboard.
+Exec=robo-ricochet
+Icon=robo-ricochet
+Terminal=false
+StartupNotify=false
+Categories=Games;