summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChih-Hsuan Yen2023-06-07 00:55:37 +0800
committerChih-Hsuan Yen2023-06-07 00:55:37 +0800
commitf59a4b2b2e354913328dda765e86dcefd3266e1b (patch)
treeca6871d44a95b35e7140b9511166abcea365a444
parent47383ea6af8a5cd4e70ccebcca85266c964ee68c (diff)
downloadaur-f59a4b2b2e354913328dda765e86dcefd3266e1b.tar.gz
logcat-color3: upgrade to 0.10.0
* Switch to signed git tags - PyPI PGP support is gone [1] * Switch to PEP 517 [1] https://blog.pypi.org/posts/2023-05-23-removing-pgp/
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD26
2 files changed, 22 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e128952894c0..b90a9ae81f83 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,21 @@
pkgbase = logcat-color3
pkgdesc = A colorful and highly configurable alternative to the standard "adb logcat" command from the Android SDK
- pkgver = 0.9.2
+ pkgver = 0.10.0
pkgrel = 1
url = https://github.com/yan12125/logcat-color3
arch = any
license = Apache
+ makedepends = git
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
makedepends = python-setuptools-scm
makedepends = python-wheel
depends = python
depends = python-colorama
conflicts = logcat-color
- source = https://files.pythonhosted.org/packages/source/l/logcat-color3/logcat-color3-0.9.2.tar.gz
- source = https://files.pythonhosted.org/packages/source/l/logcat-color3/logcat-color3-0.9.2.tar.gz.asc
+ source = git+https://github.com/yan12125/logcat-color3?signed#tag=ee5c73183b4ab58e0103bddbe1119632ce43e500
validpgpkeys = E62545315B012B69C8C94A1D56EC201BFC794362
- sha256sums = a1da09de689470c323576014e7644f4987e7866846d1a785b53eab2a324dcb40
sha256sums = SKIP
pkgname = logcat-color3
diff --git a/PKGBUILD b/PKGBUILD
index 3a113bea5ae5..fed0cbead08d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,39 @@
# Contributor: Thomas Weißschuh <thomas t-8ch de>
pkgname=logcat-color3
-pkgver=0.9.2
+pkgver=0.10.0
+# curl https://api.github.com/repos/yan12125/logcat-color3/git/ref/tags/v$pkgver | jq -r .object.sha
+_tag=ee5c73183b4ab58e0103bddbe1119632ce43e500
pkgrel=1
pkgdesc='A colorful and highly configurable alternative to the standard "adb logcat" command from the Android SDK'
arch=(any)
url='https://github.com/yan12125/logcat-color3'
license=(Apache)
depends=(python python-colorama)
-makedepends=(python-setuptools-scm python-wheel)
+makedepends=(git python-build python-installer python-setuptools python-setuptools-scm python-wheel)
conflicts=(logcat-color)
-source=("https://files.pythonhosted.org/packages/source/l/logcat-color3/logcat-color3-$pkgver.tar.gz"{,.asc})
-sha256sums=('a1da09de689470c323576014e7644f4987e7866846d1a785b53eab2a324dcb40'
- 'SKIP')
+source=("git+https://github.com/yan12125/logcat-color3?signed#tag=$_tag")
+sha256sums=('SKIP')
validpgpkeys=(
'E62545315B012B69C8C94A1D56EC201BFC794362' # Chih-Hsuan Yen <yan12125@archlinux.org>
)
+pkgver() {
+ cd logcat-color3
+ git describe --tags | sed 's/^v//'
+}
+
build() {
- cd logcat-color3-$pkgver
- python setup.py build
+ cd logcat-color3
+ python -m build --wheel --no-isolation
}
check() {
- cd logcat-color3-$pkgver
+ cd logcat-color3
python -m unittest discover ./test
}
package() {
- cd logcat-color3-$pkgver
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ cd logcat-color3
+ python -m installer --destdir="$pkgdir" dist/*.whl
}