summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStorm Dragon2019-12-10 14:43:43 -0500
committerStorm Dragon2019-12-10 14:43:43 -0500
commitf5a29d7a8be163f51f67265de3479f2e166cf743 (patch)
tree24ae5a3492a3ed985cadeeba2a8c3dad46283f8a
parentb4c11b02a790958a015b81582527c4abe108041b (diff)
downloadaur-f5a29d7a8be163f51f67265de3479f2e166cf743.tar.gz
Updated dependancies and improved the prepare function.
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 687fcc07e2e0..2ac7b0759c91 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,6 +11,7 @@ pkgbase = numnastics-git
depends = python-pyperclip
depends = python-requests
depends = python-xdg
+ depends = speech-dispatcher
provides = numnastics
conflicts = numnastics
source = git+https://gitlab.com/stormdragon2976/numnastics.git
diff --git a/PKGBUILD b/PKGBUILD
index 6d640e565bce..c35934c3eaaa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgdesc="A number puzzle audio game"
arch=('any')
url="https://gitlab.com/stormdragon2976/numnastics"
license=('GPL3')
-depends=('python' 'python-pygame' 'python-pyperclip' 'python-requests' 'python-xdg')
+depends=('python' 'python-pygame' 'python-pyperclip' 'python-requests' 'python-xdg' 'speech-dispatcher')
makedepends=('git')
provides=("$_pkgname")
conflicts=("$_pkgname")
@@ -25,7 +25,7 @@ pkgver() {
prepare() {
cd "${_pkgname}"
- git submodule update --init
+ git submodule update --init --remote --merge
}
package() {