summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2015-04-15 23:37:58 +0200
committerCarsten Teibes2015-04-15 23:37:58 +0200
commitf5b170712430ec76ea511ae9dfde5b97755e4f8f (patch)
treed9f287d6dd6c419be1e2535428273186ab2deb1b
downloadaur-f5b170712430ec76ea511ae9dfde5b97755e4f8f.tar.gz
[add] yamagi-quake2-ctf-git
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD46
-rw-r--r--yamagi-quake2-ctf.desktop10
-rw-r--r--yamagi-quake2-ctf.sh3
4 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4286c9706e59
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = yamagi-quake2-ctf-git
+ pkgdesc = Quake II - Three Wave Capture The Flag for yamagi-quake2 (development version)
+ pkgver = 1.02.r5.ge2b397d
+ pkgrel = 1
+ url = http://www.yamagi.org/quake2/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = custom
+ depends = sh
+ depends = yamagi-quake2
+ provides = yamagi-quake2-ctf
+ conflicts = yamagi-quake2-ctf
+ source = yamagi-quake2-ctf::git+https://github.com/yquake2/ctf.git
+ source = yamagi-quake2-ctf.sh
+ source = yamagi-quake2-ctf.desktop
+ sha256sums = SKIP
+ sha256sums = 9a9abd8d720a719180713163261fed154ec34787c82dda2b9465aefd9890b64c
+ sha256sums = da8c69eb05eb9aab8526616b2808c7535ae38c1e28b5e7db341ff633bc09be31
+
+pkgname = yamagi-quake2-ctf-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d7357d2c747
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+
+pkgname=yamagi-quake2-ctf-git
+pkgver=1.02.r5.ge2b397d
+pkgrel=1
+arch=('i686' 'x86_64')
+pkgdesc="Quake II - Three Wave Capture The Flag for yamagi-quake2 (development version)"
+url="http://www.yamagi.org/quake2/"
+license=('GPL' 'custom')
+depends=('sh' 'yamagi-quake2')
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
+source=(${pkgname%-*}::"git+https://github.com/yquake2/ctf.git"
+ "${pkgname%-*}.sh"
+ "${pkgname%-*}.desktop")
+sha256sums=('SKIP'
+ '9a9abd8d720a719180713163261fed154ec34787c82dda2b9465aefd9890b64c'
+ 'da8c69eb05eb9aab8526616b2808c7535ae38c1e28b5e7db341ff633bc09be31')
+
+pkgver() {
+ cd ${pkgname%-*}
+ git describe --long --tags | sed 's/^CTF_//;s/_/./;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ make -C ${pkgname%-*}
+}
+
+package() {
+ cd ${pkgname%-*}
+
+ # game launcher
+ install -Dm755 ../${pkgname%-*}.sh "$pkgdir"/usr/bin/${pkgname%-*}
+
+ # game library
+ install -Dm644 release/game.so "$pkgdir"/usr/share/yamagi-quake2/ctf/game.so
+
+ # doc
+ install -Dm644 README "$pkgdir"/usr/share/doc/${pkgname%-*}/README
+
+ # desktop entry
+ install -Dm644 ../${pkgname%-*}.desktop "$pkgdir"/usr/share/applications/${pkgname%-*}.desktop
+
+ # license
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/yamagi-quake2-ctf.desktop b/yamagi-quake2-ctf.desktop
new file mode 100644
index 000000000000..4c857c13d1d0
--- /dev/null
+++ b/yamagi-quake2-ctf.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=Quake II - Three Wave Capture The Flag
+Comment=Yamagi Quake II
+Icon=yamagi-quake2
+Exec=yamagi-quake2-ctf
+Categories=Game;Shooter;
+Terminal=false
+StartupNotify=false
diff --git a/yamagi-quake2-ctf.sh b/yamagi-quake2-ctf.sh
new file mode 100644
index 000000000000..0cd4f4b681ad
--- /dev/null
+++ b/yamagi-quake2-ctf.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec yamagi-quake2 +set game ctf $*