summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhillip Smith2015-06-02 10:25:00 +1000
committerPhillip Smith2015-06-02 10:25:00 +1000
commitf5b1bac593e5098073010e26b8d3cc730398d186 (patch)
treef765bf50bc43f372c2b83c6fd44ac9ed9a337e5f
downloadaur-f5b1bac593e5098073010e26b8d3cc730398d186.tar.gz
initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD71
-rw-r--r--autoreconf.patch11
-rw-r--r--dump-buildfix.patch27
-rw-r--r--restore-rmdir.patch11
6 files changed, 144 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..caebc81a64ce
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = dump
+ pkgdesc = Standard *nix for performing backups to tapedrive from ext2 and ext3 filesystems
+ pkgver = 0.4b44
+ pkgrel = 4
+ url = http://dump.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = autoconf
+ makedepends = automake
+ makedepends = pkg-config
+ depends = e2fsprogs
+ source = http://downloads.sourceforge.net/dump/dump-0.4b44.tar.gz
+ source = dump-buildfix.patch
+ source = autoreconf.patch
+ source = restore-rmdir.patch
+ md5sums = daec97b1ad905c904eba926221f4be6d
+ md5sums = c412b47327240f4daecb68ba2f6a7730
+ md5sums = 28615ed3146ae28f14050fab65ae712d
+ md5sums = 85bd0d8238a5010a4823d6c9642dc75b
+
+pkgname = dump
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4a3d82ac4f55
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+/dump-*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c3b21aa4ee6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,71 @@
+# Maintainer: Phillip Smith <fukawi2@NO-SPAM.gmail.com>
+# http://github.com/fukawi2/aur-packages
+# Contributor: gregor <gregor@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+### I AM ONLY THE PACKAGER, NOT THE DEVELOPER
+### Please ask support questions about this software in one of:
+### 1) The AUR comments; OR
+### 2) Upstream forums/maillist etc; OR
+### 3) The ArchLinux forums
+### I do not always know enough about the software itself, or don't have the
+### time to promptly respond to direct emails.
+### If you have found a problem with the package/PKGBUILD (as opposed to
+### the software) then please do email me or post an AUR comment.
+
+pkgname=dump
+pkgver=0.4b44
+pkgrel=4
+pkgdesc="Standard *nix for performing backups to tapedrive from ext2 and ext3 filesystems"
+arch=('i686' 'x86_64')
+url="http://dump.sourceforge.net/"
+license=('BSD')
+depends=('e2fsprogs')
+makedepends=('autoconf' 'automake' 'pkg-config')
+source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+ 'dump-buildfix.patch'
+ 'autoreconf.patch'
+ 'restore-rmdir.patch')
+md5sums=('daec97b1ad905c904eba926221f4be6d'
+ 'c412b47327240f4daecb68ba2f6a7730'
+ '28615ed3146ae28f14050fab65ae712d'
+ '85bd0d8238a5010a4823d6c9642dc75b')
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ # source: http://sourceforge.net/p/dump/bugs/157/
+ patch -p0 < "$srcdir"/restore-rmdir.patch
+
+ # source: http://sourceforge.net/p/dump/patches/16/
+ patch < "$srcdir"/dump-buildfix.patch
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --with-manowner=root \
+ --with-mangrp=root \
+ --with-manmode=644 \
+ --with-bingrp=root \
+ --disable-readline \
+ --disable-rmt \
+ --disable-transselinux
+
+ # upstream uses "autoconf" but that fails, so patch to use "autoreconf"
+ patch < "$srcdir"/autoreconf.patch
+
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ make prefix="$pkgdir"/usr install
+
+ # the upstream Makefile doesn't care for --sbindir to work with
+ # prefix=$pkgdir so manhandle /usr/sbin to /usr/bin
+ mv -f "$pkgdir"/usr/sbin/ "$pkgdir"/usr/bin
+
+ install -Dm644 COPYRIGHT "$pkgdir"/usr/share/licenses/dump/COPYRIGHT
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/autoreconf.patch b/autoreconf.patch
new file mode 100644
index 000000000000..9ca2e2876fd1
--- /dev/null
+++ b/autoreconf.patch
@@ -0,0 +1,11 @@
+--- Makefile.OLD 2013-12-02 12:03:00.352853949 +1100
++++ Makefile 2013-12-02 12:03:17.991990818 +1100
+@@ -73,7 +73,7 @@
+ (cd $(top_builddir); ./config.status)
+
+ $(top_srcdir)/configure: $(top_srcdir)/configure.in
+- cd $(top_srcdir) && autoconf
++ cd $(top_srcdir) && autoreconf
+
+ $(top_srcdir)/config.h.in: $(top_srcdir)/configure.in
+ cd $(top_srcdir) && autoheader
diff --git a/dump-buildfix.patch b/dump-buildfix.patch
new file mode 100644
index 000000000000..15d5a0c7da8f
--- /dev/null
+++ b/dump-buildfix.patch
@@ -0,0 +1,27 @@
+diff -up dump-0.4b44/configure.in.buildfix dump-0.4b44/configure.in
+--- dump-0.4b44/configure.in.buildfix 2011-06-14 14:37:49.659652746 +0200
++++ dump-0.4b44/configure.in 2011-06-14 14:40:47.361349814 +0200
+@@ -415,6 +415,11 @@ if test "$ext2fs_h" = no -o "x$EXT2FS_LI
+ AC_MSG_ERROR(You need to install the Ext2fs libraries from the E2fsprogs distribution first - hint: make install-libs)
+ fi
+
++PKG_CHECK_MODULES(COM_ERR, [com_err])
++if test -n "$STATIC" ; then
++ COM_ERR_LIBS=`$PKG_CONFIG --libs --static com_err`
++fi
++
+ dnl
+ dnl Check for ext2fs_read_inode_full
+ dnl
+diff -up dump-0.4b44/MCONFIG.in.buildfix dump-0.4b44/MCONFIG.in
+--- dump-0.4b44/MCONFIG.in.buildfix 2011-06-14 14:41:00.869323616 +0200
++++ dump-0.4b44/MCONFIG.in 2011-06-14 14:41:12.947300187 +0200
+@@ -40,7 +40,7 @@ GINC+= @EXT2FS_CFLAGS@
+ # indicate where the ext2fs library can be found (this is not needed if you
+ # have run `make install-libs' in the e2fsprogs source directory).
+ #GLIBDIR= -L/usr/src/e2fsprogs-0.5c/lib
+-GLIBS= $(GLIBDIR) -L../compat/lib -lcompat @EXT2FS_LIBS@
++GLIBS= $(GLIBDIR) -L../compat/lib -lcompat @EXT2FS_LIBS@ @COM_ERR_LIBS@
+
+ #
+ # Definitions (don't change them unless you know what you are doing)
diff --git a/restore-rmdir.patch b/restore-rmdir.patch
new file mode 100644
index 000000000000..45566f966171
--- /dev/null
+++ b/restore-rmdir.patch
@@ -0,0 +1,11 @@
+--- restore/restore.c 2015-01-19 10:50:21.629933524 +1100
++++ restore/restore.c 2015-01-19 10:51:09.219934850 +1100
+@@ -593,7 +593,7 @@
+ if (np->e_type == LEAF) {
+ removeleaf(np);
+ freeentry(np);
+- } else {
++ } else if (np->e_ino != 0) {
+ np->e_flags |= TMPNAME;
+ deleteino(np->e_ino);
+ np->e_next = removelist;