summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobbert van der Helm2021-11-16 17:14:00 +0100
committerRobbert van der Helm2021-11-16 17:14:00 +0100
commitf5bcd32f4f46dba3ac93a72f13d7aa1fbe625216 (patch)
treebf2d546f01c166841f9c965112f00bed59481acb
parent43b2c220588a5fb4825e6c13f2938ec24281b261 (diff)
downloadaur-f5bcd32f4f46dba3ac93a72f13d7aa1fbe625216.tar.gz
Make updating wraps more resilient to errors
-rw-r--r--PKGBUILD5
1 files changed, 2 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c888005ffdba..d9a4390f8ccc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,11 +28,10 @@ build() {
# Make sure all of our wraps are up to date because Meson won't update
# wrap subprojects that already exist
- meson subprojects download
# XXX: These two commands will just error out for wrap-file wraps. Any file
# based wraps are manually versioned anyways so that should be fine.
- meson subprojects update --types git
- meson subprojects packagefiles --apply --types git
+ meson subprojects update --types git | true
+ meson subprojects packagefiles --apply --types git | true
# If you don't want to build lib32-boost-libs and you don't need the 32-bit
# bitbridge, then you can leave out the dependency for it and set the