summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2021-03-04 15:31:04 -0500
committerGuillaume Horel2021-03-04 15:48:48 -0500
commitf5dacdb9d752fba4c6be5f4f7e6c9296fa42ce91 (patch)
treeea0b9faf7382c34c2374058c5b3d9bfbb6e9e1e4
parenta39cd9b0d1490d5a02b558c0a7d995222ea6cd04 (diff)
downloadaur-f5dacdb9d752fba4c6be5f4f7e6c9296fa42ce91.tar.gz
bump to 1.4.9
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD27
2 files changed, 13 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 301d1638e36a..33578574e20a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zstd-static
pkgdesc = Zstandard - Fast real-time compression algorithm
- pkgver = 1.4.5
+ pkgver = 1.4.9
pkgrel = 1
url = http://www.zstd.net/
arch = x86_64
@@ -12,8 +12,8 @@ pkgbase = zstd-static
provides = zstd
conflicts = zstd
options = staticlibs
- source = https://github.com/facebook/zstd/archive/v1.4.5.tar.gz
- sha256sums = 734d1f565c42f691f8420c8d06783ad818060fc390dee43ae0a89f86d0a4f8c2
+ source = https://github.com/facebook/zstd/archive/v1.4.9.tar.gz
+ sha256sums = acf714d98e3db7b876e5b540cbf6dee298f60eb3c0723104f6d3f065cd60d6a8
pkgname = zstd-static
diff --git a/PKGBUILD b/PKGBUILD
index 21c4ef7640bb..89f317cf56a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=zstd-static
_pkgname=${pkgname%-static}
-pkgver=1.4.5
+pkgver=1.4.9
pkgrel=1
pkgdesc='Zstandard - Fast real-time compression algorithm'
arch=('x86_64')
@@ -14,32 +14,25 @@ depends=('zlib' 'xz' 'lz4')
makedepends=('cmake')
options=('staticlibs')
source=("https://github.com/facebook/zstd/archive/v${pkgver}.tar.gz")
-sha256sums=('734d1f565c42f691f8420c8d06783ad818060fc390dee43ae0a89f86d0a4f8c2')
+sha256sums=('acf714d98e3db7b876e5b540cbf6dee298f60eb3c0723104f6d3f065cd60d6a8')
provides=('zstd')
conflicts=('zstd')
build() {
- cd "$srcdir/$_pkgname-$pkgver/build"
- mkdir builddir
- cd builddir
- cmake -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=/usr/lib \
- ../cmake
- make
+ cmake -B build -S "$_pkgname-${pkgver}/build/cmake" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib
+ make -C build
}
package() {
- cd "$srcdir/$_pkgname-$pkgver"
- pushd "build/builddir"
- pushd lib
- make DESTDIR="$pkgdir/" install
- popd; pushd programs
- make DESTDIR="$pkgdir" install
- popd; popd
+ make DESTDIR="$pkgdir/" -C build/lib install
+ make DESTDIR="$pkgdir" -C build/programs install
+ cd "$_pkgname-${pkgver}"
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
check() {
- cd "$srcdir/$_pkgname-$pkgver"
+ cd "$_pkgname-$pkgver"
make check
}