summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Cholasta2022-12-15 20:47:38 +0100
committerJan Cholasta2022-12-15 20:47:38 +0100
commitf5e3e364393bc841c7161667515d7434bc3d14ab (patch)
tree5c521a3c6d088621bb2ae4697e0be167ef99949d
parent6497acf77ba4963af87f71bc658e11d16b525b3b (diff)
downloadaur-f5e3e364393bc841c7161667515d7434bc3d14ab.tar.gz
gzdoom-git-4.11pre+8+gde65d1b96-1
-rw-r--r--.SRCINFO4
-rw-r--r--0001-Fix-file-paths.patch46
-rw-r--r--PKGBUILD22
3 files changed, 23 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52177ab32ba1..fa5ac588bf04 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gzdoom-git
pkgdesc = Feature centric port for all Doom engine games (git version)
- pkgver = 4.10pre+16+gd422737a7
+ pkgver = 4.11pre+8+gde65d1b96
pkgrel = 1
url = http://www.zdoom.org/
arch = i686
@@ -45,7 +45,7 @@ pkgbase = gzdoom-git
source = 0001-Fix-file-paths.patch
sha256sums = SKIP
sha256sums = 59122e670f72aa2531aff370e7aaab2d886a7642e79e91f27a533d3b4cad4f6d
- sha256sums = 195a9d1ec0489bd38f1d6c40763e66773dd74f5f719acb6afa32a077fdb0b8f4
+ sha256sums = a37dde8274e1a9fd511af951da2e362d503ab4be72e79d4843e1ca3a0129549f
optdepends_x86_64 = vulkan-driver: Vulkan renderer
optdepends_x86_64 = vulkan-icd-loader: Vulkan renderer
diff --git a/0001-Fix-file-paths.patch b/0001-Fix-file-paths.patch
index cc8adb641d4a..5df3f66c809e 100644
--- a/0001-Fix-file-paths.patch
+++ b/0001-Fix-file-paths.patch
@@ -1,43 +1,17 @@
-From 99e82d0644fee9a21e967b7b8708ff253e7528d5 Mon Sep 17 00:00:00 2001
+From 749acb5c34edad113b083e37df034887674aad3e Mon Sep 17 00:00:00 2001
From: Jan Cholasta <jan@cholasta.net>
Date: Tue, 25 Feb 2020 12:53:07 +0100
Subject: [PATCH] Fix file paths
---
- src/common/platform/posix/sdl/i_main.cpp | 14 +-------------
- src/gameconfigfile.cpp | 10 ++--------
- 2 files changed, 3 insertions(+), 21 deletions(-)
+ src/gameconfigfile.cpp | 10 ++--------
+ 1 file changed, 2 insertions(+), 8 deletions(-)
-diff --git a/src/common/platform/posix/sdl/i_main.cpp b/src/common/platform/posix/sdl/i_main.cpp
-index a28b90f01..7299029fd 100644
---- a/src/common/platform/posix/sdl/i_main.cpp
-+++ b/src/common/platform/posix/sdl/i_main.cpp
-@@ -175,19 +175,7 @@ int main (int argc, char **argv)
- Args = new FArgs(argc, argv);
-
- // Should we even be doing anything with progdir on Unix systems?
-- char program[PATH_MAX];
-- if (realpath (argv[0], program) == NULL)
-- strcpy (program, argv[0]);
-- char *slash = strrchr (program, '/');
-- if (slash != NULL)
-- {
-- *(slash + 1) = '\0';
-- progdir = program;
-- }
-- else
-- {
-- progdir = "./";
-- }
-+ progdir = "/usr/lib/gzdoom/";
-
- I_StartupJoysticks();
-
diff --git a/src/gameconfigfile.cpp b/src/gameconfigfile.cpp
-index 17898f3ae..7bfb63205 100644
+index 82b8071b60..a6584fa6f5 100644
--- a/src/gameconfigfile.cpp
+++ b/src/gameconfigfile.cpp
-@@ -119,8 +119,6 @@ FGameConfigFile::FGameConfigFile ()
+@@ -121,8 +121,6 @@ FGameConfigFile::FGameConfigFile ()
// Arch Linux likes them in /usr/share/doom
// Debian likes them in /usr/share/games/doom
// I assume other distributions don't do anything radically different
@@ -46,7 +20,7 @@ index 17898f3ae..7bfb63205 100644
SetValueForKey ("Path", "/usr/share/doom", true);
SetValueForKey ("Path", "/usr/share/games/doom", true);
#endif
-@@ -141,8 +139,6 @@ FGameConfigFile::FGameConfigFile ()
+@@ -143,8 +141,6 @@ FGameConfigFile::FGameConfigFile ()
SetValueForKey ("Path", "$HOME/" GAME_DIR, true);
SetValueForKey ("Path", "$HOME/.local/share/games/doom", true);
SetValueForKey ("Path", SHARE_DIR, true);
@@ -55,7 +29,7 @@ index 17898f3ae..7bfb63205 100644
SetValueForKey ("Path", "/usr/share/doom", true);
SetValueForKey ("Path", "/usr/share/games/doom", true);
#endif
-@@ -170,10 +166,8 @@ FGameConfigFile::FGameConfigFile ()
+@@ -172,10 +168,8 @@ FGameConfigFile::FGameConfigFile ()
SetValueForKey("Path", "$HOME/" GAME_DIR "/fm_banks", true);
SetValueForKey("Path", "$HOME/.local/share/games/doom/soundfonts", true);
SetValueForKey("Path", "$HOME/.local/share/games/doom/fm_banks", true);
@@ -63,11 +37,11 @@ index 17898f3ae..7bfb63205 100644
- SetValueForKey("Path", "/usr/local/share/doom/fm_banks", true);
- SetValueForKey("Path", "/usr/local/share/games/doom/soundfonts", true);
- SetValueForKey("Path", "/usr/local/share/games/doom/fm_banks", true);
-+ SetValueForKey("Path", "/usr/share/" GAMENAMELOWERCASE "/soundfonts", true);
-+ SetValueForKey("Path", "/usr/share/" GAMENAMELOWERCASE "/fm_banks", true);
++ SetValueForKey("Path", "$PROGDIR/soundfonts", true);
++ SetValueForKey("Path", "$PROGDIR/fm_banks", true);
SetValueForKey("Path", "/usr/share/doom/soundfonts", true);
SetValueForKey("Path", "/usr/share/doom/fm_banks", true);
SetValueForKey("Path", "/usr/share/games/doom/soundfonts", true);
--
-2.34.1
+2.38.1
diff --git a/PKGBUILD b/PKGBUILD
index 6f6814a6cbf2..966b4fba3bcb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jan Cholasta <grubber at grubber cz>
pkgname=gzdoom-git
-pkgver=4.10pre+16+gd422737a7
+pkgver=4.11pre+8+gde65d1b96
pkgrel=1
pkgdesc='Feature centric port for all Doom engine games (git version)'
arch=('i686' 'x86_64' 'aarch64')
@@ -42,7 +42,7 @@ source=('gzdoom::git+https://github.com/coelckers/gzdoom.git'
'0001-Fix-file-paths.patch')
sha256sums=('SKIP'
'59122e670f72aa2531aff370e7aaab2d886a7642e79e91f27a533d3b4cad4f6d'
- '195a9d1ec0489bd38f1d6c40763e66773dd74f5f719acb6afa32a077fdb0b8f4')
+ 'a37dde8274e1a9fd511af951da2e362d503ab4be72e79d4843e1ca3a0129549f')
pkgver() {
cd gzdoom
@@ -59,7 +59,11 @@ build() {
mkdir -p build
cmake -B build \
-D CMAKE_BUILD_TYPE=Release \
- -D CMAKE_CXX_FLAGS="${CXXFLAGS} -ffile-prefix-map=\"$PWD\"=. -DSHARE_DIR=\\\"/usr/share/gzdoom\\\"" \
+ -D CMAKE_CXX_FLAGS="$CXXFLAGS -ffile-prefix-map=\"$PWD\"=. -DSHARE_DIR=\\\"/usr/share/gzdoom\\\"" \
+ -D CMAKE_INSTALL_PREFIX=/usr \
+ -D SYSTEMINSTALL=ON \
+ -D INSTALL_PK3_PATH=share/gzdoom \
+ -D INSTALL_SOUNDFONT_PATH=share/gzdoom \
-D INSTALL_RPATH=/usr/lib \
-D DYN_GTK=OFF \
-D DYN_OPENAL=OFF
@@ -68,13 +72,9 @@ build() {
package() {
cd gzdoom
- install build/gzdoom -t "$pkgdir"/usr/bin -D
- install build/{game_support,gzdoom}.pk3 -t "$pkgdir"/usr/lib/gzdoom -D -m 644
+ make -C build install DESTDIR="$pkgdir"
+ install -d "$pkgdir"/usr/share/licenses
+ mv "$pkgdir"/usr/share/doc/gzdoom/licenses "$pkgdir"/usr/share/licenses/gzdoom
desktop-file-install "$srcdir"/gzdoom.desktop --dir="$pkgdir"/usr/share/applications
- install docs/{console,rh-log,skins}.* -t "$pkgdir"/usr/share/doc/gzdoom -D -m 644
- install build/{brightmaps,game_widescreen_gfx,lights}.pk3 -t "$pkgdir"/usr/share/gzdoom -D -m 644
- install build/soundfonts/gzdoom.sf2 -t "$pkgdir"/usr/share/gzdoom/soundfonts -D -m 644
- install build/fm_banks/* -t "$pkgdir"/usr/share/gzdoom/fm_banks -D -m 644
- install src/posix/zdoom.xpm "$pkgdir"/usr/share/icons/hicolor/256x256/apps/gzdoom.xpm -D -m 644
- install docs/licenses/{bsd,fxaa,gdtoa,README}.* -t "$pkgdir"/usr/share/licenses/$pkgname -D -m 644
+ install src/posix/zdoom.xpm -D -m 644 "$pkgdir"/usr/share/icons/hicolor/256x256/apps/gzdoom.xpm
}