summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormeepzh2016-06-12 02:53:06 -0400
committermeepzh2016-06-12 02:53:06 -0400
commitf6258db04e7fcb8642f13cbaa9ccaac4f363fa9f (patch)
treefc6e6f216372622e3e4cdc12416b71073b960adb
parentea5142b064dd3e634175ae25a9105f17f6843f9f (diff)
downloadaur-f6258db04e7fcb8642f13cbaa9ccaac4f363fa9f.tar.gz
fixed license permissions, reduced PKGBUILD line length
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD17
2 files changed, 13 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06b81303754c..a8f0de90cbef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = seexpr-git
pkgdesc = An embeddable expression evaluation engine
pkgver = 2.9.r0.g36ffb81
- pkgrel = 1
+ pkgrel = 2
url = http://www.disneyanimation.com/technology/seexpr.html
arch = i686
arch = x86_64
- license = custom:SeExpr
+ license = custom
makedepends = cmake>=2.4.6
makedepends = git
optdepends = python2-pyqt4: required for SeExpr editor
diff --git a/PKGBUILD b/PKGBUILD
index 500a16b42d2f..3e597b6540aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,23 @@
# Maintainer: meepzh <meep.aur@meepzh.com>
pkgname=seexpr-git
pkgver=2.9.r0.g36ffb81
-pkgrel=1
+pkgrel=2
pkgdesc="An embeddable expression evaluation engine"
arch=(i686 x86_64)
url="http://www.disneyanimation.com/technology/seexpr.html"
-license=('custom:SeExpr')
+license=('custom')
optdepends=('python2-pyqt4: required for SeExpr editor')
makedepends=('cmake>=2.4.6' 'git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=('git+https://github.com/wdas/SeExpr.git' 'build-info.patch' 'CMakeLists.txt.patch' 'Editor_CMakeLists.txt.patch')
-md5sums=('SKIP' 'bb56b587bca21debebf86b7adb6242f1' '0b04cc77edebf6d364767cad0a988ef2' '69721fc7e11747cfbc7f0712b4975f79')
+source=('git+https://github.com/wdas/SeExpr.git'
+ 'build-info.patch'
+ 'CMakeLists.txt.patch'
+ 'Editor_CMakeLists.txt.patch')
+md5sums=('SKIP'
+ 'bb56b587bca21debebf86b7adb6242f1'
+ '0b04cc77edebf6d364767cad0a988ef2'
+ '69721fc7e11747cfbc7f0712b4975f79')
pkgver() {
cd "$srcdir/SeExpr"
@@ -41,6 +47,5 @@ package() {
cd "$srcdir/SeExpr/build"
make DESTDIR="$pkgdir/" install
# Copy custom Apache license
- mkdir -p "$pkgdir/usr/share/licenses/${pkgname}"
- cp "../LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 "../LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}