summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Wojdyła2023-06-27 19:24:10 +0200
committerMichał Wojdyła2023-06-27 19:24:10 +0200
commitf67a1e0027aee33d0e996e5b161b4f23eb970b89 (patch)
tree7d5b3be3cf792aee1329c3b06cf5673376221cc6
parent371afc06f5e8843a3647cb283930ed7285d32267 (diff)
downloadaur-f67a1e0027aee33d0e996e5b161b4f23eb970b89.tar.gz
update to 0.2.2
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD44
-rw-r--r--haskell-aosd.install18
-rw-r--r--haskell-aosd.patch12
4 files changed, 33 insertions, 69 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 01683306e6e9..3362f8b88e4b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,23 @@
pkgbase = haskell-aosd
pkgdesc = Bindings to libaosd, a library for Cairo-based on-screen displays
- pkgver = 0.2.1
+ pkgver = 0.2.2
pkgrel = 1
url = http://hackage.haskell.org/package/aosd
- install = haskell-aosd.install
arch = i686
arch = x86_64
license = custom:BSD3
- depends = ghc
- depends = haskell-x11
- depends = haskell-bindings-dsl>=1.0.11
- depends = haskell-cairo>=0.12
- depends = haskell-colour
- depends = haskell-monad-control
- depends = haskell-pango>=0.12
- depends = haskell-transformers
- depends = libaosd
+ makedepends = ghc
+ makedepends = haskell-x11
+ makedepends = haskell-bindings-dsl
+ makedepends = haskell-cairo
+ makedepends = haskell-colour
+ makedepends = haskell-monad-control
+ makedepends = haskell-pango
+ makedepends = libaosd
+ depends = ghc-libs
options = strip
options = staticlibs
- source = http://hackage.haskell.org/packages/archive/aosd/0.2.1/aosd-0.2.1.tar.gz
- source = haskell-aosd.patch
- md5sums = fc63d1e99278a7807225feab46c22900
- md5sums = 7f3e8aaa61345b80d148105759cbe2c8
+ source = http://hackage.haskell.org/packages/archive/aosd/0.2.2/aosd-0.2.2.tar.gz
+ md5sums = 60d5c95bdd327e225d618e461bbde2d9
pkgname = haskell-aosd
-
diff --git a/PKGBUILD b/PKGBUILD
index f013cf1cfded..662f2765d225 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,37 @@
-# Maintainer: Leif Warner <abimlech@gmail.com>
+# Contributor: Leif Warner <abimlech@gmail.com>
_hkgname=aosd
pkgname=haskell-aosd
-pkgver=0.2.1
+pkgver=0.2.2
pkgrel=1
pkgdesc="Bindings to libaosd, a library for Cairo-based on-screen displays"
url="http://hackage.haskell.org/package/${_hkgname}"
license=('custom:BSD3')
arch=('i686' 'x86_64')
-depends=('ghc' 'haskell-x11' 'haskell-bindings-dsl>=1.0.11' 'haskell-cairo>=0.12' 'haskell-colour' 'haskell-monad-control' 'haskell-pango>=0.12' 'haskell-transformers' 'libaosd')
+depends=('ghc-libs')
+makedepends=('ghc' 'haskell-x11' 'haskell-bindings-dsl' 'haskell-cairo' 'haskell-colour' 'haskell-monad-control' 'haskell-pango' 'libaosd')
options=('strip' 'staticlibs')
-source=(http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz haskell-aosd.patch)
-install=${pkgname}.install
-md5sums=('fc63d1e99278a7807225feab46c22900'
- '7f3e8aaa61345b80d148105759cbe2c8')
-prepare() {
- cd ${srcdir}/${_hkgname}-${pkgver}
- patch -p1 -i $srcdir/haskell-aosd.patch
-}
+source=(http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
+md5sums=('60d5c95bdd327e225d618e461bbde2d9')
build() {
- cd ${srcdir}/${_hkgname}-${pkgver}
- runhaskell Setup configure -O ${PKGBUILD_HASKELL_ENABLE_PROFILING:+-p } --enable-split-objs --enable-shared \
- --prefix=/usr --docdir=/usr/share/doc/${pkgname} --libsubdir=\$compiler/site-local/\$pkgid
+ cd "${srcdir}/${_hkgname}-${pkgver}"
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir="/usr/share/doc/${pkgname}" --datasubdir="$pkgname" \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
runhaskell Setup build
runhaskell Setup haddock
- runhaskell Setup register --gen-script
+ runhaskell Setup register --gen-script
runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
}
+
package() {
- cd ${srcdir}/${_hkgname}-${pkgver}
- install -D -m744 register.sh ${pkgdir}/usr/share/haskell/${pkgname}/register.sh
- install -m744 unregister.sh ${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh
- install -d -m755 ${pkgdir}/usr/share/doc/ghc/html/libraries
- ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}
- runhaskell Setup copy --destdir=${pkgdir}
- install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
- rm -f ${pkgdir}/usr/share/doc/${pkgname}/LICENSE
+ cd ${_hkgname}-${pkgver}
+ install -D -m744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
+ install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
+ install -d -m755 "${pkgdir}/usr/share/doc/ghc/html/libraries"
+ ln -s /usr/share/doc/${pkgname}/html "${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}"
+ runhaskell Setup copy --destdir="${pkgdir}"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
}
diff --git a/haskell-aosd.install b/haskell-aosd.install
deleted file mode 100644
index 7583ca881559..000000000000
--- a/haskell-aosd.install
+++ /dev/null
@@ -1,18 +0,0 @@
-HS_DIR=usr/share/haskell/haskell-aosd
-post_install() {
- ${HS_DIR}/register.sh
- (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
-}
-pre_upgrade() {
- ${HS_DIR}/unregister.sh
-}
-post_upgrade() {
- ${HS_DIR}/register.sh
- (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
-}
-pre_remove() {
- ${HS_DIR}/unregister.sh
-}
-post_remove() {
- (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
-}
diff --git a/haskell-aosd.patch b/haskell-aosd.patch
deleted file mode 100644
index 942da392f00a..000000000000
--- a/haskell-aosd.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -auar aosd-0.2.1/Graphics/Aosd/Pango.hs aosd-0.2.1.patched/Graphics/Aosd/Pango.hs
---- aosd-0.2.1/Graphics/Aosd/Pango.hs 2014-03-22 11:04:09.000000000 -0700
-+++ aosd-0.2.1.patched/Graphics/Aosd/Pango.hs 2015-06-28 20:57:40.285757171 -0700
-@@ -230,7 +230,7 @@
- case tcText of
- Empty -> return ()
- PlainText s -> layoutSetText layout (s "")
-- PangoMarkup s -> void (layoutSetMarkup layout (s ""))
-+ PangoMarkup s -> void (layoutSetMarkup layout (s "") :: IO String)
-
- let go :: (PangoLayout -> a -> IO ()) -> Maybe a -> IO ()
- go f = maybeDo (f layout)