summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Tinkham2016-10-03 11:45:55 -0600
committerJonathan Tinkham2016-10-03 11:45:55 -0600
commitf6be20b3ecfa155c73ecc98a5367d5cceef27776 (patch)
tree7b2c319493953eb3bad29f913e571c8f2370629f
parent4771c1c6fba406e0aa8feabf16be97e6336e71c8 (diff)
downloadaur-f6be20b3ecfa155c73ecc98a5367d5cceef27776.tar.gz
Fix yaml.h conflict
This still seems to build the internal dependency regardless of flag, and likely needs to be patched. Works well, but still requires libyaml for yaml.h
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98c15ad39c00..d7978041da80 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = octopus
pkgdesc = A scientific program aimed at ab initio virtual experimentation
pkgver = 6.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.tddft.org/programs/octopus/
arch = i686
arch = x86_64
@@ -13,6 +13,7 @@ pkgbase = octopus
depends = arpack
depends = libxc
depends = gd
+ depends = libyaml
source = http://www.tddft.org/programs/octopus/download/6.0/octopus-6.0.tar.gz
sha256sums = 4a802ee86c1e06846aa7fa317bd2216c6170871632c9e03d020d7970a08a8198
diff --git a/PKGBUILD b/PKGBUILD
index 37ac7c7f878e..f709671008ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=octopus
pkgver=6.0
-pkgrel=1
+pkgrel=2
pkgdesc="A scientific program aimed at ab initio virtual experimentation"
arch=('i686' 'x86_64')
url="http://www.tddft.org/programs/octopus/"
license=('GPL')
-depends=('gsl' 'fftw' 'arpack' 'libxc' 'gd')
+depends=('gsl' 'fftw' 'arpack' 'libxc' 'gd' 'libyaml')
makedepends=('gcc' 'gcc-fortran')
source=(http://www.tddft.org/programs/octopus/download/${pkgver}/octopus-${pkgver}.tar.gz)
sha256sums=('4a802ee86c1e06846aa7fa317bd2216c6170871632c9e03d020d7970a08a8198')
@@ -26,4 +26,7 @@ check() {
package() {
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
+
+ # This yaml.h file is still copied regardless...
+ rm ${pkgdir}/usr/include/yaml.h
}