summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosh Dye2016-04-10 12:42:56 -0700
committerJosh Dye2016-04-10 12:42:56 -0700
commitf6d5d6a943a125043206184b7d5508fa27b450ae (patch)
tree8494f11d0e79570a3e82ff49c3c1f5bac5ba5004
downloadaur-f6d5d6a943a125043206184b7d5508fa27b450ae.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
-rw-r--r--gtkatlantic.desktop9
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1bc68548613b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = gtkatlantic
+ pkgdesc = Monopoly board game client for the monopd server.
+ pkgver = git
+ pkgrel = 1
+ url = http://gtkatlantic.gradator.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = gtk3
+ depends = git
+ depends = muparser
+ depends = utf8cpp
+ source = git+git://git.tuxfamily.org/gitroot/gtkatlantic/gtkatlantic.git
+ source = gtkatlantic.desktop
+ md5sums = SKIP
+ md5sums = 8f570f9210682354b21517e6692ed08a
+
+pkgname = gtkatlantic
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b2a21118b2d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Josh Dye <josh.jpenguin@gmail.com>
+# Contributor: Tasos Latsas < tlatsas2000 at gmail dot com >
+# Contributor: Thomas Dziedzic < gostrc at gmail >
+# Contributor: damir <damir@archlinux.org>
+# Contributor: Kritoke <typeolinux@yahoo.com>
+# Contributor: caemir
+
+pkgname=gtkatlantic
+pkgver=git
+pkgrel=1
+pkgdesc="Monopoly board game client for the monopd server."
+arch=("i686" "x86_64")
+url="http://gtkatlantic.gradator.net/"
+license=("GPL")
+depends=("gtk3" "git" "muparser" "utf8cpp")
+source=("git+git://git.tuxfamily.org/gitroot/gtkatlantic/gtkatlantic.git"
+ "gtkatlantic.desktop")
+
+md5sums=("SKIP"
+ "8f570f9210682354b21517e6692ed08a")
+
+build() {
+ cd "${srcdir}/gtkatlantic"
+
+ ./autogen.sh --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/gtkatlantic/"
+
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 $srcdir/$pkgname.desktop \
+ $pkgdir/usr/share/applications/$pkgname.desktop
+}
diff --git a/gtkatlantic.desktop b/gtkatlantic.desktop
new file mode 100644
index 000000000000..186dbb4f08a9
--- /dev/null
+++ b/gtkatlantic.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=GtkAtlantic
+GenericName=Monopd network client
+Comment=Connect to a Monopd server
+Exec=gtkatlantic
+Icon=gtkatlantic
+Categories=Game;BoardGame;
+