summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2016-04-22 17:58:07 -0600
committerJohn D Jones III2016-04-22 17:58:07 -0600
commitf7290d048f91ea92e3b75eba9aa6253ed8afc0f5 (patch)
treeff5e182a4e54a9e9d0c63d520e96d15aeb6b477c
parent7b4458b6bad0e78f7c55362ed3ce2cbd85c82036 (diff)
downloadaur-f7290d048f91ea92e3b75eba9aa6253ed8afc0f5.tar.gz
Fix test
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
-rw-r--r--test_pod.patch10
3 files changed, 22 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd190b7d1a30..6270096a9683 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,19 @@
+# Generated by mksrcinfo v8
+# Fri Apr 22 23:57:43 UTC 2016
pkgbase = perl-io-util
pkgdesc = A selection of general-utility IO function
pkgver = 1.5
pkgrel = 1
- url = http://search.cpan.org/dist/IO-Util
+ url = https://metacpan.org/release/IO-Util
arch = any
license = PerlArtistic
license = GPL
depends = perl
options = !emptydirs
source = http://search.cpan.org/CPAN/authors/id/D/DO/DOMIZIO/IO-Util-1.5.tar.gz
+ source = test_pod.patch
md5sums = 520ce0056f3e5816ae82bc93bf413507
- sha512sums = 5936241cdab8d601523efe1f2e9d3c7b3a99e46f59eb9a1ea7d273f2c1d36c6bdc75d2c5483d36f65e498384756a59adc0ba82a50bb4d7c34d5c73d52faa8867
+ md5sums = 01f1451584758582a3835d278df90125
pkgname = perl-io-util
diff --git a/PKGBUILD b/PKGBUILD
index a981eca9387a..e43a9f1c4e41 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
-# Generator : CPANPLUS::Dist::Arch 1.25
+# Contributor: John D Jones III AKA jnbek <jnbek1972 -_AT_- g m a i l -_Dot_- com>
+# Generator : CPANPLUS::Dist::Arch 1.32
pkgname='perl-io-util'
pkgver='1.5'
@@ -10,10 +10,10 @@ license=('PerlArtistic' 'GPL')
options=('!emptydirs')
depends=('perl')
makedepends=()
-url='http://search.cpan.org/dist/IO-Util'
-source=('http://search.cpan.org/CPAN/authors/id/D/DO/DOMIZIO/IO-Util-1.5.tar.gz')
-md5sums=('520ce0056f3e5816ae82bc93bf413507')
-sha512sums=('5936241cdab8d601523efe1f2e9d3c7b3a99e46f59eb9a1ea7d273f2c1d36c6bdc75d2c5483d36f65e498384756a59adc0ba82a50bb4d7c34d5c73d52faa8867')
+url='https://metacpan.org/release/IO-Util'
+source=('http://search.cpan.org/CPAN/authors/id/D/DO/DOMIZIO/IO-Util-1.5.tar.gz' 'test_pod.patch')
+md5sums=('520ce0056f3e5816ae82bc93bf413507'
+ '01f1451584758582a3835d278df90125')
_distdir="IO-Util-1.5"
build() {
@@ -24,6 +24,7 @@ build() {
MODULEBUILDRC=/dev/null
cd "$srcdir/$_distdir"
+ patch -Np1 -i ../test_pod.patch
/usr/bin/perl Makefile.PL
make
)
diff --git a/test_pod.patch b/test_pod.patch
new file mode 100644
index 000000000000..4242880ecb91
--- /dev/null
+++ b/test_pod.patch
@@ -0,0 +1,10 @@
+--- IO-Util-1.5/t/test_pod.t.orig 2016-04-22 17:55:26.026666668 -0600
++++ IO-Util-1.5/t/test_pod.t 2016-04-22 17:55:33.306666668 -0600
+@@ -5,6 +5,7 @@ use Test::More;
+
+ eval "use Test::Pod 1.00";
+ plan skip_all => "Test::Pod 1.00 required for testing POD" if $@;
++plan skip_all => 'these tests are for authors only!' unless $ENV{AUTHOR_TESTING} or $ENV{RELEASE_TESTING};
+ my @poddirs = qw( blib ../lib);
+ all_pod_files_ok( all_pod_files( @poddirs ) );
+