summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreshrh2021-06-08 15:48:29 -0400
committereshrh2021-06-08 15:48:29 -0400
commitf72b52c3130e2d90cd5d9d02454769e433997efd (patch)
tree7046686c6bc6489c2a2bb3c0cc60cc98e3af7e1f
parent5fc154dde5e42da0a6d1a544c855746aca0d6985 (diff)
downloadaur-f72b52c3130e2d90cd5d9d02454769e433997efd.tar.gz
revert to non-poetry
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD25
2 files changed, 20 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e391ede2a94..eb52a352559c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = jrnl-git
pkgdesc = Collect your thoughts and notes without leaving the command line
pkgver = v2.8.1.r12.g5e87ff1
- pkgrel = 5
+ pkgrel = 2
url = https://jrnl.sh/
arch = any
license = GPL3
checkdepends = python-behave
checkdepends = python-pytest
checkdepends = python-black
- checkdepends = python-poetry
makedepends = git
- makedepends = make
+ makedepends = python-dephell
+ makedepends = python-setuptools
depends = python
depends = python-ansiwrap
depends = python-asteval
diff --git a/PKGBUILD b/PKGBUILD
index bebbfb08709b..166daf9e7216 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
pkgname=jrnl-git
_gitname=jrnl
pkgver=v2.8.1.r12.g5e87ff1
-pkgrel=5
+pkgrel=2
pkgdesc="Collect your thoughts and notes without leaving the command line"
arch=('any')
url="https://jrnl.sh/"
license=('GPL3')
depends=('python' 'python-ansiwrap' 'python-asteval' 'python-colorama' 'python-cryptography' 'python-keyring' 'python-parsedatetime' 'python-dateutil' 'python-pyxdg' 'python-pyaml')
-checkdepends=('python-behave' 'python-pytest' 'python-black' 'python-poetry')
-makedepends=('git' 'make')
+checkdepends=('python-behave' 'python-pytest' 'python-black')
+makedepends=('git' 'python-dephell' 'python-setuptools')
conflicts=("jrnl")
source=("git+https://github.com/jrnl-org/jrnl.git")
md5sums=('SKIP')
@@ -22,16 +22,25 @@ pkgver() {
check() {
cd "$_gitname"
+ pytest .
+ behave --no-skipped --format progress
+
black setup.py --diff | patch
- make test
+ black --check --diff .
+}
+
+prepare() {
+ cd "$_gitname"
+ dephell deps convert --from pyproject.toml --to setup.py --envs main
}
build() {
cd "$_gitname"
- make install
-}
+ python setup.py build
+}
-package(){
- true
+package() {
+ cd "$_gitname"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}