summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukáš Jirkovský2015-05-31 20:19:29 +0200
committerLukáš Jirkovský2015-05-31 20:24:23 +0200
commitf75177d275ea7c6ef7c818531b3c130259e8bc1d (patch)
treec4052430de3c9f07c0b1e80a8685648111d6ba2c
downloadaur-f75177d275ea7c6ef7c818531b3c130259e8bc1d.tar.gz
initial commit
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD42
-rw-r--r--aqsis.install14
-rw-r--r--imfinputfile-forward-declaration.diff18
4 files changed, 104 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..29ce7a79cb89
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = aqsis
+ pkgdesc = A high quality, photorealistic, 3D rendering solution
+ pkgver = 1.8.2
+ pkgrel = 2
+ url = http://www.aqsis.org
+ install = aqsis.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ makedepends = boost
+ makedepends = openexr
+ makedepends = libpng
+ makedepends = qt4
+ makedepends = mesa
+ depends = boost-libs
+ depends = openexr
+ depends = hicolor-icon-theme
+ depends = shared-mime-info
+ depends = desktop-file-utils
+ optdepends = qt4: graphical interface
+ optdepends = libgl: ptview
+ options = !libtool
+ source = http://downloads.sourceforge.net/project/aqsis/aqsis-source/1.8.2/aqsis-1.8.2.tar.gz
+ source = imfinputfile-forward-declaration.diff
+ md5sums = 399967e99f12cfbd1a7385c4e1d39c3b
+ md5sums = e52f27d3041e88a63531b691ad05a6aa
+
+pkgname = aqsis
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7bf21e2a23a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Lukas Jirkovsky <l.jirkovsky@gmail.com>
+# Contributor: Gino Pezzin <pezzin@gmail.com>
+pkgname=aqsis
+pkgver=1.8.2
+pkgrel=2
+pkgdesc="A high quality, photorealistic, 3D rendering solution"
+arch=('i686' 'x86_64')
+url="http://www.aqsis.org"
+license=('GPL2')
+optdepends=('qt4: graphical interface' 'libgl: ptview')
+depends=('boost-libs' 'openexr' 'hicolor-icon-theme' 'shared-mime-info' 'desktop-file-utils')
+makedepends=('cmake' 'boost' 'openexr' 'libpng' 'qt4' 'mesa')
+options=('!libtool')
+install=aqsis.install
+source=(http://downloads.sourceforge.net/project/aqsis/aqsis-source/$pkgver/$pkgname-$pkgver.tar.gz \
+ imfinputfile-forward-declaration.diff)
+md5sums=('399967e99f12cfbd1a7385c4e1d39c3b'
+ 'e52f27d3041e88a63531b691ad05a6aa')
+
+prepare() {
+ cd "$srcdir"/$pkgname-$pkgver
+ # fix build with OpenEXR 2.0 (?)
+ patch -Np1 < "$srcdir"/imfinputfile-forward-declaration.diff || true
+}
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ mkdir -p "$srcdir"/$pkgname-build
+ cd "$srcdir"/$pkgname-build
+
+ cmake "$srcdir"/$pkgname-$pkgver \
+ -DCMAKE_SKIP_RPATH=ON \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DSYSCONFDIR=/etc/aqsis
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgname-build
+ make DESTDIR="$pkgdir" install
+}
diff --git a/aqsis.install b/aqsis.install
new file mode 100644
index 000000000000..b2086e07b579
--- /dev/null
+++ b/aqsis.install
@@ -0,0 +1,14 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor/
+ update-mime-database usr/share/mime > /dev/null
+ update-desktop-database -q
+}
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/imfinputfile-forward-declaration.diff b/imfinputfile-forward-declaration.diff
new file mode 100644
index 000000000000..b931a66b0b3f
--- /dev/null
+++ b/imfinputfile-forward-declaration.diff
@@ -0,0 +1,18 @@
+diff -rup aqsis-1.8.2/libs/tex/io/exrinputfile.h aqsis-1.8.2.new/libs/tex/io/exrinputfile.h
+--- aqsis-1.8.2/libs/tex/io/exrinputfile.h 2012-08-24 13:26:50.000000000 +0100
++++ aqsis-1.8.2.new/libs/tex/io/exrinputfile.h 2013-04-29 17:50:17.556770200 +0100
+@@ -48,10 +48,11 @@
+
+ #include <aqsis/tex/io/itexinputfile.h>
+
++#include <OpenEXR/ImfInputFile.h>
+ //------------------------------------------------------------------------------
+-namespace Imf {
+- class InputFile;
+-}
++//namespace Imf {
++// class InputFile;
++//}
+
+ namespace Aqsis {
+