summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-11-13 16:34:02 +0800
committerzxp198210052023-11-13 16:34:02 +0800
commitf76af78ad1f7b8a3d7bb1a86c456799f5b7f9f50 (patch)
treed574944a15ee02cd62db32e39caa12db281d6f22
parent512487e3a36489fa6f25ad21e72f283f0209e472 (diff)
downloadaur-f76af78ad1f7b8a3d7bb1a86c456799f5b7f9f50.tar.gz
fix errors
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD27
2 files changed, 20 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c804f16d24ce..4fa1dbd25628 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wapiti
pkgdesc = Comprehensive web app vulnerability scanner written in Python
pkgver = 3.1.7
- pkgrel = 3
+ pkgrel = 4
url = https://wapiti-scanner.github.io
arch = any
license = GPL2
diff --git a/PKGBUILD b/PKGBUILD
index 367c07d09768..f482d8b02e9e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,30 @@
# Contributor : mickael9 <mickael9 at gmail dot com>
pkgname=wapiti
pkgver=3.1.7
-pkgrel=3
+pkgrel=4
pkgdesc='Comprehensive web app vulnerability scanner written in Python'
arch=('any')
url="https://wapiti-scanner.github.io"
-_githuburl="https://github.com/wapiti-scanner/wapiti"
+_ghurl="https://github.com/wapiti-scanner/wapiti"
license=('GPL2')
makedepends=('python-setuptools')
-depends=('python>=3.9' 'python-cryptography' 'python-soupsieve' 'python-mako' 'python-setuptools' \
- 'python-beautifulsoup4' 'python-httpx')
-optdepends=('python-requests-kerberos: Kerberos authentication'
- 'python-requests-ntlm: NTLM authentication')
-options=('zipman')
-source=("${pkgname}-${pkgver}.tar.gz::${_githuburl}/releases/download/${pkgver}/${pkgname}3-${pkgver}.tar.gz")
+depends=(
+ 'python>=3.9'
+ 'python-cryptography'
+ 'python-soupsieve'
+ 'python-mako'
+ 'python-setuptools'
+ 'python-beautifulsoup4'
+ 'python-httpx'
+)
+optdepends=(
+ 'python-requests-kerberos: Kerberos authentication'
+ 'python-requests-ntlm: NTLM authentication'
+)
+options=(
+ 'zipman'
+)
+source=("${pkgname}-${pkgver}.tar.gz::${_ghurl}/releases/download/${pkgver}/${pkgname}3-${pkgver}.tar.gz")
sha256sums=('8489ddc82fd1cc9ee20861eaecfbaa2edaba46c0d25d3331329ff58bb50dc921')
package() {
cd "${srcdir}/${pkgname}3-${pkgver}"