summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2023-06-14 21:27:18 +0800
committerUniversebenzene2023-06-14 21:27:18 +0800
commitf778ed92cbea2ff0d2e99107891710f6e6deec43 (patch)
tree20bc79f14743783acd32a567f6634fc81888bc89
parenta23a5eb5bf3c8deca5368278be75ec7e8efbaab0 (diff)
downloadaur-f778ed92cbea2ff0d2e99107891710f6e6deec43.tar.gz
Update to version 5.0.0
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD16
2 files changed, 19 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe9298938113..0621793bce9f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-sunpy
pkgdesc = Python library for solar physics
- pkgver = 4.1.7
+ pkgver = 5.0.0
pkgrel = 1
url = https://sunpy.org
arch = i686
@@ -12,23 +12,23 @@ pkgbase = python-sunpy
makedepends = python-installer
makedepends = python-extension-helpers
makedepends = python-numpy
- source = https://files.pythonhosted.org/packages/source/s/sunpy/sunpy-4.1.7.tar.gz
- md5sums = b3a7013c913fdbfc951023c80dbcfa82
+ source = https://files.pythonhosted.org/packages/source/s/sunpy/sunpy-5.0.0.tar.gz
+ md5sums = f30c2e69e026dff2c1fda08b307c28a8
pkgname = python-sunpy
- depends = python>=3.8
- depends = python-astropy>=4.2.1
- depends = python-parfive>=1.2.0
+ depends = python>=3.9
+ depends = python-astropy>=5.0.1
+ depends = python-parfive>=2.0.0
depends = python-aioftp
depends = python-packaging>=19.0
optdepends = python-asdf>=2.8.0: asdf
optdepends = python-asdf-astropy>=0.1.1: asdf
- optdepends = python-dask>=2.0.0: dask
+ optdepends = python-dask>=2021.4.0: dask
optdepends = python-sqlalchemy>=1.3.4: database
- optdepends = python-scikit-image>=0.16.0: image
+ optdepends = python-scikit-image>=0.18.0: image
optdepends = python-scipy>1.10.0: image, map
optdepends = python-reproject: map
- optdepends = python-matplotlib>=3.3.0: map, timeseries, visualization
+ optdepends = python-matplotlib>=3.5.0: map, timeseries, visualization
optdepends = python-mpl-animators>=1.0.0: map, visualization
optdepends = python-glymur>0.9.5: jpeg2000
optdepends = python-lxml>=4.8.0: jpeg2000
@@ -38,6 +38,6 @@ pkgname = python-sunpy
optdepends = python-tqdm>=4.32.1: net
optdepends = python-zeep>=3.4.0: net
optdepends = python-cdflib>0.4.0: timeseries
- optdepends = python-h5netcdf>=0.8.1: timeseries
+ optdepends = python-h5netcdf>=0.11: timeseries
optdepends = python-h5py>=3.1.0: timeseries
- optdepends = python-pandas>=1.0.0: timeseries
+ optdepends = python-pandas>=1.2.0: timeseries
diff --git a/PKGBUILD b/PKGBUILD
index a84951326548..a49ab048d1f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgbase=python-sunpy
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
#"python-${_pyname}-doc")
-pkgver=4.1.7
+pkgver=5.0.0
pkgrel=1
pkgdesc="Python library for solar physics"
arch=('i686' 'x86_64')
@@ -63,7 +63,7 @@ source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname
# "http://data.sunpy.org/sunpy/v1/aiacalibim5.fits.gz"
# "http://data.sunpy.org/sunpy/v1/glg_cspec_n5_110607_v00.pha")
## "http://netdrms01.nispdc.nso.edu/VSO/WSDL/VSOi_rpc_literal.wsdl")
-md5sums=('b3a7013c913fdbfc951023c80dbcfa82')
+md5sums=('f30c2e69e026dff2c1fda08b307c28a8')
# 'bde3bd7a691b38e2e4c4e1d17b143b24'
# '01efaf052d81efc32a92050a249aa557'
# 'ead6d3ce4c183c471d76bf1bc3be44a3'
@@ -136,15 +136,15 @@ build() {
#}
package_python-sunpy() {
- depends=('python>=3.8' 'python-astropy>=4.2.1' 'python-parfive>=1.2.0' 'python-aioftp' 'python-packaging>=19.0')
+ depends=('python>=3.9' 'python-astropy>=5.0.1' 'python-parfive>=2.0.0' 'python-aioftp' 'python-packaging>=19.0')
optdepends=('python-asdf>=2.8.0: asdf'
'python-asdf-astropy>=0.1.1: asdf'
- 'python-dask>=2.0.0: dask'
+ 'python-dask>=2021.4.0: dask'
'python-sqlalchemy>=1.3.4: database'
- 'python-scikit-image>=0.16.0: image'
+ 'python-scikit-image>=0.18.0: image'
'python-scipy>1.10.0: image, map'
'python-reproject: map'
- 'python-matplotlib>=3.3.0: map, timeseries, visualization'
+ 'python-matplotlib>=3.5.0: map, timeseries, visualization'
'python-mpl-animators>=1.0.0: map, visualization'
'python-glymur>0.9.5: jpeg2000'
'python-lxml>=4.8.0: jpeg2000'
@@ -154,9 +154,9 @@ package_python-sunpy() {
'python-tqdm>=4.32.1: net'
'python-zeep>=3.4.0: net'
'python-cdflib>0.4.0: timeseries'
- 'python-h5netcdf>=0.8.1: timeseries'
+ 'python-h5netcdf>=0.11: timeseries'
'python-h5py>=3.1.0: timeseries'
- 'python-pandas>=1.0.0: timeseries')
+ 'python-pandas>=1.2.0: timeseries')
# 'python-sunpy-doc: Documentation for SunPy')
cd ${srcdir}/${_pyname}-${pkgver}