summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Shalygin2017-11-13 15:41:39 +0700
committerKonstantin Shalygin2017-11-13 15:41:39 +0700
commitf77dec8e4559bc5a6d470c1b9973f53007a9a8f5 (patch)
treea773ee6130b005c020e21eea52a26500756c1cac
parentdbc53ae03fd518dcbb91da2d004bf20a910efe99 (diff)
downloadaur-f77dec8e4559bc5a6d470c1b9973f53007a9a8f5.tar.gz
Allow to define linux_custom package.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
-rw-r--r--ipt_iftag.install3
3 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d1e8f7b39c43..1b098c24293d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Fri Aug 18 09:12:54 UTC 2017
+# Mon Nov 13 08:41:11 UTC 2017
pkgbase = ipt_iftag
pkgdesc = Netfilter extension that can operate on groups of interfaces.
pkgver = 6.04d141a
diff --git a/PKGBUILD b/PKGBUILD
index 59b660ce7452..6d524b65a15c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,8 @@ makedepends=('git' 'libtool' 'gcc' 'gzip' 'gawk' 'sed')
source=("${pkgname}::git+${url}")
sha256sums=('SKIP')
install="${pkgname}.install"
-_kernver="`pacman -Ql linux| awk '/(\/modules\/)([0-9.-])+-ARCH\/$/ {print $2}'`"
+_linux_custom="ARCH"
+_kernver="`pacman -Ql linux| awk '/(\/modules\/)([0-9.-])+-'${_linux_custom}'\/$/ {print $2}'`"
pkgver() {
cd "${srcdir}/${pkgname}"
@@ -23,6 +24,7 @@ pkgver() {
}
build() {
+ echo ${_kernver}
cd "${srcdir}/${pkgname}"
make KERNEL_DIR="${_kernver}build"
}
diff --git a/ipt_iftag.install b/ipt_iftag.install
index b49fe6130f68..0bddbd3b8950 100644
--- a/ipt_iftag.install
+++ b/ipt_iftag.install
@@ -1,5 +1,6 @@
post_install() {
- kernver="`pacman -Ql linux|gawk 'match($0, /^(.*)modules\/([0-9.-]+-ARCH)\/$/, a) {print a[2]}'`"
+ linux_custom="ARCH"
+ kernver="`pacman -Ql linux|gawk 'match($0, /^(.*)modules\/([0-9.-]+-'${linux_custom}')\/$/, a) {print a[2]}'`"
echo -e "Probe modules"
depmod ${kernver}
}