summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Weißschuh2015-02-15 23:31:45 +0000
committerThomas Weißschuh2015-02-15 23:31:45 +0000
commitf78f07409f4e037132528272e831bf6c38afa5cf (patch)
tree5a7488f789cbbaceb68e5f14b12ead0114a14032
downloadaur-f78f07409f4e037132528272e831bf6c38afa5cf.tar.gz
add unp
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3ee75650e6b7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-unp
+ pkgdesc = Command line tool that can unpack archives easily
+ pkgver = 0.2
+ pkgrel = 1
+ url = https://github.com/mitsuhiko/unp
+ arch = any
+ license = BSD
+ depends = python-click
+ source = http://pypi.python.org/packages/source/u/unp/unp-0.2.tar.gz
+ sha256sums = e0f4b4512ff4e4bfa2655a3625f18f7a52ec84f5cc99a2501ba6a981edd35b39
+
+pkgname = python-unp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..deb4691c63ee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Thomas Weißschuh <thomas t-8ch.de>
+
+pkgname=python-unp
+pkgver=0.2
+pkgrel=1
+pkgdesc='Command line tool that can unpack archives easily'
+arch=('any')
+url='https://github.com/mitsuhiko/unp'
+license=('BSD')
+depends=('python-click')
+source=("http://pypi.python.org/packages/source/u/unp/unp-${pkgver}.tar.gz")
+
+
+build() {
+ cd "${srcdir}/unp-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/unp-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}
+
+sha256sums=('e0f4b4512ff4e4bfa2655a3625f18f7a52ec84f5cc99a2501ba6a981edd35b39')