summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Handley2017-10-09 07:08:10 +0100
committerWill Handley2017-10-09 07:08:10 +0100
commitf79c095470dbb71710a0c520871a860c92d63ed5 (patch)
tree69a8f277555ef7fa85a354e19c5edd097027ef76
parent8b5f2eb4b43325bf199512263b92fa4cadf7ffaf (diff)
downloadaur-f79c095470dbb71710a0c520871a860c92d63ed5.tar.gz
Added checks
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD20
2 files changed, 15 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4b6129bcceed..60b3dc24b9bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lalframe
pkgdesc = The LIGO Scientific Consortium Algorithm Library Suite. lalframe
pkgver = 1.4.3
- pkgrel = 2
+ pkgrel = 3
url = https://wiki.ligo.org/DASWG/LALSuiteInstall
arch = any
groups = lalsuite
diff --git a/PKGBUILD b/PKGBUILD
index a31f4dde7cf6..550384cf5011 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
pkgname=lalframe
+_pkgname=${pkgname}
pkgver=1.4.3
-pkgrel=2
-pkgdesc="The LIGO Scientific Consortium Algorithm Library Suite. lalframe"
+pkgrel=3
+pkgdesc="The LIGO Scientific Consortium Algorithm Library Suite. ${_pkgname}"
arch=(any)
url="https://wiki.ligo.org/DASWG/LALSuiteInstall"
license=('unknown')
@@ -15,12 +16,19 @@ replaces=()
backup=()
options=(!emptydirs)
install=
-source=("http://software.ligo.org/lscsoft/source/lalsuite/${pkgname}-${pkgver}.tar.xz")
+source=("http://software.ligo.org/lscsoft/source/lalsuite/${_pkgname}-${pkgver}.tar.xz")
sha256sums=('cbb6ed39abb5a02d792523fc53208330cf8adf02bc4290cac635d42577acb5b1')
-package() {
- cd "$srcdir/${pkgname}-${pkgver}"
+build() {
+ cd "$srcdir/${_pkgname}-${pkgver}"
sed -i 's/\-Werror//g' configure
- ./configure --prefix=$pkgdir/usr
+ ./configure --prefix=$pkgdir/usr CFLAGS=-O3
make -j
+}
+package() {
+ cd "$srcdir/${_pkgname}-${pkgver}"
make install
}
+check() {
+ cd "$srcdir/${_pkgname}-${pkgver}"
+ make -j check
+}