summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2023-11-26 18:47:55 -0500
committerSolomon Choina2023-11-26 18:47:55 -0500
commitf7aeda8c88ba1d0988f47a12be7a576bd20661eb (patch)
tree8e36fdde195e436b22f69455e7433ce6e41c9149
parent879142baef78b2920a54cbf41eec71d7f719e372 (diff)
downloadaur-f7aeda8c88ba1d0988f47a12be7a576bd20661eb.tar.gz
making more changes
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD55
-rw-r--r--gio-querymodules.hook3
-rw-r--r--gio-querymodules.script7
4 files changed, 50 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 109702893639..9b41c1dee4a0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = glib2-selinux
pkgdesc = Low level core library
- pkgver = 2.78.0
+ pkgver = 2.78.1
pkgrel = 1
url = https://wiki.gnome.org/Projects/GLib
arch = x86_64
license = LGPL
+ makedepends = dbus
makedepends = gettext
makedepends = gtk-doc
makedepends = shared-mime-info
@@ -14,17 +15,19 @@ pkgbase = glib2-selinux
makedepends = util-linux
makedepends = meson
makedepends = dbus
- makedepends = sysprof
makedepends = libselinux
depends = pcre
depends = libffi
depends = util-linux-libs
depends = zlib
- source = git+https://gitlab.gnome.org/GNOME/glib.git#tag=2.78.0
+ depends = libsysprof-capture
+ options = debug
+ options = staticlibs
+ source = git+https://gitlab.gnome.org/GNOME/glib.git#commit=21624e78f013ee8706483086e3086076d08fe242
+ source = git+https://gitlab.gnome.org/GNOME/gvdb.git
source = noisy-glib-compile-schemas.diff
source = glib-compile-schemas.hook
source = gio-querymodules.hook
- source = gio-querymodules.script
sha256sums = SKIP
sha256sums = 81a4df0b638730cffb7fa263c04841f7ca6b9c9578ee5045db6f30ff0c3fc531
sha256sums = 64ae5597dda3cc160fc74be038dbe6267d41b525c0c35da9125fbf0de27f9b25
@@ -36,16 +39,18 @@ pkgname = glib2-selinux
depends = libffi
depends = util-linux-libs
depends = zlib
+ depends = libsysprof-capture
depends = libmount.so
optdepends = python: gdbus-codegen, glib-genmarshal, glib-mkenums, gtester-report
optdepends = libelf: gresource inspection tool
optdepends = libselinux: selinux support
+ optdepends = gvfs: most gio functionality
provides = libgio-2.0.so
provides = libglib-2.0.so
provides = libgmodule-2.0.so
provides = libgobject-2.0.so
provides = libgthread-2.0.so
- provides = glib2=2.78.0
+ provides = glib2=2.78.1
conflicts = glib2
pkgname = glib2-selinux-docs
diff --git a/PKGBUILD b/PKGBUILD
index 9171b4f6de51..090ea8d9e7c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,25 @@
# Maintainer: Solomon Choina <shlomochoina@gmail.com>
pkgbase=glib2-selinux
pkgname=(glib2-selinux glib2-selinux-docs)
-pkgver=2.78.0
+pkgver=2.78.1
pkgrel=1
pkgdesc="Low level core library"
url="https://wiki.gnome.org/Projects/GLib"
license=(LGPL)
arch=(x86_64)
-depends=(pcre libffi util-linux-libs zlib)
-makedepends=(gettext gtk-doc shared-mime-info python libelf git util-linux
- meson dbus sysprof libselinux)
-_commit=79c5866d316767d06573df01bf1598a122fbecd7 # tags/2.66.5^0
-source=("git+https://gitlab.gnome.org/GNOME/glib.git#tag=$pkgver"
+depends=(pcre libffi util-linux-libs zlib libsysprof-capture)
+makedepends=(dbus gettext gtk-doc shared-mime-info python libelf git util-linux
+ meson dbus libselinux)
+options=(
+ debug
+ staticlibs
+ )
+_commit=21624e78f013ee8706483086e3086076d08fe242 # tags/2.78.1^0
+source=("git+https://gitlab.gnome.org/GNOME/glib.git#commit=$_commit"
+ "git+https://gitlab.gnome.org/GNOME/gvdb.git"
noisy-glib-compile-schemas.diff
- glib-compile-schemas.hook gio-querymodules.{hook,script})
+ glib-compile-schemas.hook gio-querymodules.hook
+ )
sha256sums=('SKIP'
'81a4df0b638730cffb7fa263c04841f7ca6b9c9578ee5045db6f30ff0c3fc531'
'64ae5597dda3cc160fc74be038dbe6267d41b525c0c35da9125fbf0de27f9b25'
@@ -33,15 +39,34 @@ prepare() {
# Suppress noise from glib-compile-schemas.hook
git apply -3 ../noisy-glib-compile-schemas.diff
+
+ git submodule init
+ git submodule set-url subprojects/gvdb "$srcdir/gvdb"
+ git -c protocol.file.allow=always submodule update
+
}
build() {
CFLAGS+=" -DG_DISABLE_CAST_CHECKS"
- arch-meson glib build \
- -D selinux=enabled \
- -D man=true \
+ local meson_options=(
+ --default-library both
+ -D glib_debug=disabled
-D gtk_doc=true
- meson compile -C build
+ -D man=true
+ -D selinux=enabled
+ -D sysprof=enabled
+ )
+
+ # Produce more debug info: GLib has a lot of useful macros
+ CFLAGS+=" -g3"
+ CXXFLAGS+=" -g3"
+
+ # use fat LTO objects for static libraries
+ CFLAGS+=" -ffat-lto-objects"
+ CXXFLAGS+=" -ffat-lto-objects"
+
+ arch-meson glib build "${meson_options[@]}"
+
}
package_glib2-selinux() {
@@ -51,17 +76,15 @@ package_glib2-selinux() {
conflicts=(glib2)
optdepends=('python: gdbus-codegen, glib-genmarshal, glib-mkenums, gtester-report'
'libelf: gresource inspection tool'
- 'libselinux: selinux support')
+ 'libselinux: selinux support'
+ 'gvfs: most gio functionality'
+ )
DESTDIR="$pkgdir" meson install -C build
install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 *.hook
install -D gio-querymodules.script "$pkgdir/usr/share/libalpm/scripts/gio-querymodules"
- # Avoid a dep on sysprof
- sed -i 's/, sysprof-capture-4//' "$pkgdir"/usr/lib/pkgconfig/*.pc
-
- export PYTHONHASHSEED=0
python -m compileall -d /usr/share/glib-2.0/codegen \
"$pkgdir/usr/share/glib-2.0/codegen"
python -O -m compileall -d /usr/share/glib-2.0/codegen \
diff --git a/gio-querymodules.hook b/gio-querymodules.hook
index 09b0c2f89c88..c566c1d15624 100644
--- a/gio-querymodules.hook
+++ b/gio-querymodules.hook
@@ -3,10 +3,9 @@ Type = Path
Operation = Install
Operation = Upgrade
Operation = Remove
-Target = usr/lib/gio/modules/
+Target = usr/lib/gio/modules/*.so
[Action]
Description = Updating GIO module cache...
When = PostTransaction
Exec = /usr/share/libalpm/scripts/gio-querymodules
-NeedsTargets
diff --git a/gio-querymodules.script b/gio-querymodules.script
deleted file mode 100644
index 5c218775790a..000000000000
--- a/gio-querymodules.script
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/bash
-
-while read -r d; do
- [[ -d $d ]] || continue
- gio-querymodules "$d"
- rmdir --ignore-fail-on-non-empty "$d"
-done