summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2022-10-27 21:53:52 +0200
committerFabioLolix2022-10-27 21:53:52 +0200
commitf7b54512a1460905b9c31a7f1c64bb4213f94f4f (patch)
tree254221331ebd4ad922ed6959092902a556a79030
parentddb93f693285259203f58c52ec087155c58ac1e3 (diff)
downloadaur-f7b54512a1460905b9c31a7f1c64bb4213f94f4f.tar.gz
update
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 25 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a1872ad8b35d..ea43ce3e6d21 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,24 @@
pkgbase = ghostwriter-git
pkgdesc = Cross-platform, aesthetic, distraction-free Markdown editor.
- pkgver = 2.1.0.r0.g2495f9b
+ pkgver = 2.1.6.r87.gd395e01
pkgrel = 1
- url = https://github.com/wereturtle/ghostwriter
- arch = i686
+ url = https://github.com/KDE/ghostwriter
arch = x86_64
+ arch = i686
license = GPL3
makedepends = git
makedepends = qt5-tools
+ makedepends = cmake
+ makedepends = extra-cmake-modules
depends = qt5-base
depends = qt5-svg
depends = hunspell
- depends = desktop-file-utils
- depends = gtk-update-icon-cache
- depends = discount
depends = qt5-webengine
- optdepends = hunspell: spell checking
+ depends = sonnet
+ depends = kxmlgui
provides = ghostwriter
conflicts = ghostwriter
- source = git+https://github.com/wereturtle/ghostwriter.git
+ source = git+https://github.com/KDE/ghostwriter.git
sha256sums = SKIP
pkgname = ghostwriter-git
diff --git a/PKGBUILD b/PKGBUILD
index 1f1151c3d211..3b857e373ec2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,17 @@
# Contributor: Philipp 'TamCore' B. <philipp [at] tamcore [dot] eu>
pkgname=ghostwriter-git
-pkgver=2.1.0.r0.g2495f9b
+pkgver=2.1.6.r87.gd395e01
pkgrel=1
pkgdesc="Cross-platform, aesthetic, distraction-free Markdown editor."
-arch=(i686 x86_64)
-url="https://github.com/wereturtle/ghostwriter"
+arch=(x86_64 i686 )
+url="https://github.com/KDE/ghostwriter"
license=('GPL3')
+depends=('qt5-base' 'qt5-svg' 'hunspell' 'qt5-webengine' 'sonnet' 'kxmlgui')
+makedepends=('git' 'qt5-tools' 'cmake' 'extra-cmake-modules') #'discount'
conflicts=('ghostwriter')
provides=('ghostwriter')
-makedepends=('git' 'qt5-tools')
-depends=('qt5-base' 'qt5-svg' 'hunspell' 'desktop-file-utils'
- 'gtk-update-icon-cache' 'discount' 'qt5-webengine')
-optdepends=('hunspell: spell checking')
-source=(git+https://github.com/wereturtle/ghostwriter.git)
+source=(git+https://github.com/KDE/ghostwriter.git)
sha256sums=('SKIP')
pkgver() {
@@ -23,13 +21,20 @@ pkgver() {
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-build() {
+prepare() {
cd "${pkgname%-git}"
- qmake PREFIX=/usr
+ [[ -d build ]] || mkdir build
+}
+
+build() {
+ cd "${pkgname%-git}/build"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
make
}
package() {
- cd "${pkgname%-git}"
- make INSTALL_ROOT="$pkgdir/" install
+ cd "${pkgname%-git}/build"
+ make DESTDIR="$pkgdir" install
+ install -D "$pkgdir/usr/man/man1/ghostwriter.1" -t "$pkgdir/usr/share/man/man1/"
+ rm -rf "$pkgdir/usr/man/"
}