summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarian Buschsieweke2016-11-04 23:12:17 +0100
committerMarian Buschsieweke2016-11-04 23:12:17 +0100
commitf7f4015a7966c287e66090007eebfef8b7c22f27 (patch)
treec8c233200ef843ed7ce77acf6208a5d4c3dd788c
downloadaur-f7f4015a7966c287e66090007eebfef8b7c22f27.tar.gz
New PKGBUILD: libfirm-git; c-lib for graph-based IR, optimizations and code gen for compilers
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
-rw-r--r--libfirm.pc12
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1474edff04a7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = libfirm-git
+ pkgdesc = A c-lib for graph-based IR, optimizations and code gen for compilers
+ pkgver = r18354.107ceb1
+ pkgrel = 1
+ url = http://pp.ipd.kit.edu/firm/Index
+ arch = any
+ license = GPL
+ makedepends = git
+ options = staticlibs
+ source = libfirm::git+http://pp.ipd.kit.edu/git/libfirm.git
+ source = libfirm.pc
+ md5sums = SKIP
+ md5sums = 39a7ef0417669487524b95460962f6c7
+
+pkgname = libfirm-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f8966e655cb0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+_reponame=libfirm
+pkgname="${_reponame}-git"
+pkgver=r18354.107ceb1
+pkgrel=1
+pkgdesc='A c-lib for graph-based IR, optimizations and code gen for compilers'
+url="http://pp.ipd.kit.edu/firm/Index"
+license=('GPL')
+arch=('any')
+makedepends=('git')
+source=("${_reponame}::git+http://pp.ipd.kit.edu/git/${_reponame}.git"
+ libfirm.pc)
+md5sums=('SKIP' '39a7ef0417669487524b95460962f6c7')
+options=(staticlibs)
+
+pkgver() {
+ cd "$_reponame"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "$_reponame"
+
+ make
+}
+
+package() {
+ cd "$_reponame"
+
+ make install PREFIX=/usr DESTDIR="$pkgdir"
+ install -Dm644 "../${_reponame}.pc" \
+ "${pkgdir}/usr/lib/pkgconfig/${_reponame}.pc"
+}
diff --git a/libfirm.pc b/libfirm.pc
new file mode 100644
index 000000000000..78c796d1a9c5
--- /dev/null
+++ b/libfirm.pc
@@ -0,0 +1,12 @@
+prefix=/usr
+exec_prefix=${prefix}
+libdir=${exec_prefix}/lib
+includedir=${prefix}/include
+
+Name: libFirm
+Description: A lib for graph-based IR, optimizations and code gen for compilers
+Version: 1.22.1
+Requires:
+Libs: -L${libdir} -lfirm
+Libs.private: -lm
+Cflags: -I${includedir}/libfirm