summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorworkonfire2021-03-21 16:41:05 +0100
committerworkonfire2021-03-21 16:41:05 +0100
commitf889b4066e5e6d5ab8982669163fbf2372f4c7c3 (patch)
treecab497b1c3958ac355d479f5a3cf92515b2833c0
downloadaur-f889b4066e5e6d5ab8982669163fbf2372f4c7c3.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD28
-rwxr-xr-xgadu-gadu5
-rwxr-xr-xgadu-gadu.desktop8
4 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6979a1983b81
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = gadu-gadu
+ pkgdesc = Gadu-Gadu is a Polish instant messaging client using a proprietary protocol.
+ pkgver = 12.4.104.12172
+ pkgrel = 1
+ url = https://gg.pl
+ arch = i686
+ arch = x86_64
+ license = custom
+ optdepends = flashplugin: needed for avatar editor
+ options = !strip
+ source = gadu-gadu.desktop::https://raw.githubusercontent.com/oliwier975PL/PKGBUILDs/master/gadu-gadu/gadu-gadu.desktop
+ source = gadu-gadu::https://raw.githubusercontent.com/oliwier975PL/PKGBUILDs/master/gadu-gadu/gadu-gadu
+ sha256sums = 8137b434801ad2f7a2a6ec5bf731e41dd381839ce55dca4082634764cea53c78
+ sha256sums = cfc55261aacbb25bdf65b3a05875cf106e1e1877b220c39ede863ee6a9631b7c
+ source_i686 = gg_32bit_12.4.104.12172.tar.bz2::http://im-updates.gg.pl/phoenix/app/release/12.4.104.12172/standard/Linux_x86-gcc3/pl/gg_32bit.tar.bz2
+ sha256sums_i686 = d53eefd156b3181057ff82738ab572bf979301ff138ce6e1c9c11bc98f809231
+ source_x86_64 = gg_64bit_12.4.104.12172.tar.bz2::http://im-updates.gg.pl/phoenix/app/release/12.4.104.12172/standard/Linux_x86_64-gcc3/pl/gg_64bit.tar.bz2
+ sha256sums_x86_64 = fc19358fe2cb1114158630825ca520a579fc6165383d37cfedc38991c162ea98
+
+pkgname = gadu-gadu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..488254165839
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: workonfire <kolucki62@gmail.com>
+
+pkgname=gadu-gadu
+pkgver=12.4.104.12172
+pkgrel=1
+pkgdesc="Gadu-Gadu is a Polish instant messaging client using a proprietary protocol."
+arch=('i686' 'x86_64')
+url="https://gg.pl"
+license=('custom')
+optdepends=('flashplugin: needed for avatar editor')
+source=("${pkgname}".desktop::https://raw.githubusercontent.com/oliwier975PL/PKGBUILDs/master/"${pkgname}"/"${pkgname}".desktop
+ "${pkgname}"::https://raw.githubusercontent.com/oliwier975PL/PKGBUILDs/master/"${pkgname}"/"${pkgname}")
+source_x86_64=(gg_64bit_"${pkgver}".tar.bz2::http://im-updates.gg.pl/phoenix/app/release/"${pkgver}"/standard/Linux_x86_64-gcc3/pl/gg_64bit.tar.bz2)
+source_i686=(gg_32bit_"${pkgver}".tar.bz2::http://im-updates.gg.pl/phoenix/app/release/"${pkgver}"/standard/Linux_x86-gcc3/pl/gg_32bit.tar.bz2)
+sha256sums=('8137b434801ad2f7a2a6ec5bf731e41dd381839ce55dca4082634764cea53c78'
+ 'cfc55261aacbb25bdf65b3a05875cf106e1e1877b220c39ede863ee6a9631b7c')
+sha256sums_i686=('d53eefd156b3181057ff82738ab572bf979301ff138ce6e1c9c11bc98f809231')
+sha256sums_x86_64=('fc19358fe2cb1114158630825ca520a579fc6165383d37cfedc38991c162ea98')
+options=(!strip)
+
+package() {
+ mkdir -p "${pkgdir}"/opt
+ mkdir -p "${pkgdir}"/usr/bin
+ mkdir -p "${pkgdir}"/usr/share/applications
+ cp -r "${srcdir}"/GG "${pkgdir}"/opt/
+ install -Dm755 "${pkgname}" "${pkgdir}"/usr/bin/
+ install -m644 "${pkgname}".desktop "${pkgdir}"/usr/share/applications/
+}
diff --git a/gadu-gadu b/gadu-gadu
new file mode 100755
index 000000000000..3677f5dafde5
--- /dev/null
+++ b/gadu-gadu
@@ -0,0 +1,5 @@
+#!/bin/bash
+
+GG_DIR=/opt/GG/
+
+LD_PRELOAD="$GG_DIR/xulrunner/libcrypto.so.1.0.0" exec "$GG_DIR/gghub" "$@"
diff --git a/gadu-gadu.desktop b/gadu-gadu.desktop
new file mode 100755
index 000000000000..0f3930ddb951
--- /dev/null
+++ b/gadu-gadu.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=GG
+Exec=env LD_PRELOAD=/opt/GG/xulrunner/libcrypto.so.1.0.0 /opt/GG/gghub --gglink %u
+Icon=/opt/GG/icons/gg.png
+Terminal=false
+Type=Application
+Categories=Utility;Network;InstantMessaging;
+MimeType=x-scheme-handler/gg;